Problem with 1047 encoder board

Comments & issues
cbronstein
Fresh meat
Posts: 1
Joined: Tue May 22, 2018 3:14 pm
Contact:

Problem with 1047 encoder board

Postby cbronstein » Tue Oct 29, 2019 3:28 pm

Playing with the 1047 but I'm having some problems. Using the Phidgets Control Panel I get errors whenever I physically attach the encoder and try to open the channel. Pretty confident I have the encoder wired correctly. The log file is below. Thanks for any help

Thanks!

****************************** Logging Enabled ******************************
* Phidget22 - Version 1.5 - Built Oct 18 2019 13:55:59 *
*******************************************************************************
2019-10-29T12:35:11 <Info> phidget22net[PhidgetNet_start()] : Starting Networking
2019-10-29T12:35:11 <Info> phidget22net[PhidgetNet_stop()] : Stopping Networking
2019-10-29T12:35:11 <Info> phidget22usb[AttachUSBDevice()] : Attaching Phidget | Path: \\?\hid#vid_06c2&pid_004f#7&120b86f2&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030} | PDO Name: \Device\000001f9
2019-10-29T12:35:11 <Info> phidget22[deviceAttach()] : 1047 (PhidgetEncoder HighSpeed 4-Input) v103 S/N:519647
2019-10-29T12:35:16 <Info> phidget22usb[PhidgetUSBOpenHandle()] : Opened USB Device: 0x43c
2019-10-29T12:35:16 <Info> phidget22[PhidgetUSBReadThreadFunction()] : 1047 (PhidgetEncoder HighSpeed 4-Input) v103 S/N:519647: USB read thread started: 0x00000698
2019-10-29T12:35:34 <Info> phidget22usb[PhidgetUSBCloseHandle()] : Closing USB Device: 0x43c
2019-10-29T12:35:34 <Info> phidget22[PhidgetUSBReadThreadFunction()] : 1047 (PhidgetEncoder HighSpeed 4-Input) v103 S/N:519647: ReadThread exiting normally (signaled by Phidget_close)
2019-10-29T12:35:36 <Info> phidget22usb[PhidgetUSBOpenHandle()] : Opened USB Device: 0x78c
2019-10-29T12:35:36 <Info> phidget22[PhidgetUSBReadThreadFunction()] : 1047 (PhidgetEncoder HighSpeed 4-Input) v103 S/N:519647: USB read thread started: 0x000016f0
2019-10-29T12:35:36 <ERROR> phidget22usb[PhidgetUSBSendPacket()] : WriteFile() failed with error code: 0x00000002 - The system cannot find the file specified.
2019-10-29T12:35:36 <ERROR> phidget22usb[PhidgetUSBSendPacket()] : WriteFile() failed with error code: 0x00000002 - The system cannot find the file specified.
2019-10-29T12:35:41 <ERROR> phidget22usb[PhidgetUSBReadPacket()] : GetOverlappedResult() in PhidgetUSBReadPacket failed with error code: 0x0000048f - The device is not connected.
2019-10-29T12:35:41 <Info> phidget22[PhidgetUSBReadThreadFunction()] : 1047 (PhidgetEncoder HighSpeed 4-Input) v103 S/N:519647: ReadThread exiting normally (Phidget detach detected in PhidgetDevice_read)

fitchett
Site Admin
Posts: 262
Joined: Fri Dec 05, 2003 3:45 pm
Location: Canada
Contact:

Re: Problem with 1047 encoder board

Postby fitchett » Tue Nov 05, 2019 2:43 pm

This can be caused by a USB low voltage brownout when power is switched on to the encoder.

Two solutions; first is to find a different USB cable (ideally shorter), and see if the issue goes away.

Another solution is re-routing the 5V (Red Wire) to the encoder. Permanently power the encoder (by bringing a wire around from the +5V on the green terminal block).


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests