Vint hub not connecting to Rasberry Pi

Comments & issues
mwulff2125
Phidgetsian
Posts: 5
Joined: Thu Oct 10, 2019 5:08 am
Contact:

Vint hub not connecting to Rasberry Pi

Postby mwulff2125 » Thu Oct 10, 2019 5:21 am

I am running rasbian and have a powered usb 2.0 hub and I am trying to connect to a vint hub HUB0000_0. I have a STC1000_0 stepper controller connected to the vint hub and a stepper connected on the controller. I can pull this up in the Windows GUI and everything works fine. When I connect this to the raspi with the hub and run HelloWorld to see if it connects I cannot get anything to show up. Any help would be appreciated.

User avatar
mparadis
Site Admin
Posts: 653
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby mparadis » Thu Oct 10, 2019 8:16 am

The USB ports on the Raspberry Pi usually don't have enough power to run devices like Phidgets. Try using an externally powered USB hub and see if it solves the issue.

mwulff2125
Phidgetsian
Posts: 5
Joined: Thu Oct 10, 2019 5:08 am
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby mwulff2125 » Thu Oct 10, 2019 10:37 am

It is an externally powered hub but still won't show up on the HelloWorld program

User avatar
mparadis
Site Admin
Posts: 653
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby mparadis » Thu Oct 10, 2019 10:52 am

Which HelloWorld program is it? Can you paste it here?

mwulff2125
Phidgetsian
Posts: 5
Joined: Thu Oct 10, 2019 5:08 am
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby mwulff2125 » Thu Oct 10, 2019 1:06 pm

It is the sample program from the website. https://www.phidgets.com/docs/OS_-_Linux#Quick_Downloads
When I run it it is just waiting for things to connect and the state does not change if I plug or unplug anything.
It just says plug and unplug
Press Enter to end anytime...

User avatar
Patrick
Lead Developer
Posts: 3098
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby Patrick » Thu Oct 10, 2019 1:07 pm

Try running as root

-Patrick

mwulff2125
Phidgetsian
Posts: 5
Joined: Thu Oct 10, 2019 5:08 am
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby mwulff2125 » Thu Oct 10, 2019 1:29 pm

Thanks a bunch, I should have done that in the first place!! Still getting my legs under me...

fitchett
Site Admin
Posts: 263
Joined: Fri Dec 05, 2003 3:45 pm
Location: Canada
Contact:

Re: Vint hub not connecting to Rasberry Pi

Postby fitchett » Tue Nov 05, 2019 2:50 pm

A comment for forums readers; newer Raspberry PIs generally have good USB voltage - and the VINT Hub is really unlikely to have power issues on -any- Raspberry PI.


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests