Correct Sensor Type for MOT2002_0 ?

Comments & issues
muretti0114
Fresh meat
Posts: 3
Joined: Mon Sep 28, 2020 3:11 am
Contact:

Correct Sensor Type for MOT2002_0 ?

Postby muretti0114 » Tue Sep 29, 2020 1:16 am

Hello,

What is the correct sensor type for MOT2002_0 Motion Sensor?

I did not find it in either VoltageInputMode or VoltageRatioMode in Phidget Control Panel (1.6.20200921), although it is shown in your manual page https://www.phidgets.com/?tier=3&catid= ... prodid=710

Also in the Java library (phidget22.jar), MOT2002_0 does not show up either in VoltageRatioSensorType or VoltageSensorType.

Considering the previous model was 1111_0 Motion sensor, I am temporally using VoltageRatioSensorType.PN_1111 instead.

Could you let me know the correct usage?

Thank you

jimd
Phidgetsian
Posts: 9
Joined: Mon Sep 21, 2020 7:49 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jimd » Tue Sep 29, 2020 8:37 am

@muretti0114

I'm using a MOT2002_0 here connected to a VINT Hub (HUB0000_0), and it's working OK as a 'DigitalInput'.

Jim

jimd
Phidgetsian
Posts: 9
Joined: Mon Sep 21, 2020 7:49 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jimd » Tue Sep 29, 2020 8:44 am

@muretti0114

If you're using the Phidget Control Panel, you can just find the correct Hub Port and double-click the item 'Hub Port - Digital Input Mode'.

You should see a pop-up window with caption 'Digital Input'. Wave you hand over the sensor and the state should change to True for a short time.

HTH,
Jim

jimd
Phidgetsian
Posts: 9
Joined: Mon Sep 21, 2020 7:49 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jimd » Tue Sep 29, 2020 9:03 am

I forgot to say that it also works as a 'VoltageInput' in the Control Panel, showing a varying analog voltage, but I get 'Saturation Detected' errors quite often - don't know why.

jdecoux
Labview Developer
Posts: 124
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jdecoux » Tue Sep 29, 2020 11:00 am

Opening the hub port as a VoltageInput will allow you to set your own limits on how sensitive your system is to detecting motion, by detecting if the sensor's voltage is outside of a given threshold.

SATURATION errors occur because the signal from the analog sensor is too large to be accurately quantified by the HUB (e.g. >5V), and should be treated as the sensor detecting motion.

jdecoux
Labview Developer
Posts: 124
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jdecoux » Tue Sep 29, 2020 11:06 am

As for the original question, it appears the MOT2002 sensor type does not currently exist, but likely should. We will look into it.

muretti0114
Fresh meat
Posts: 3
Joined: Mon Sep 28, 2020 3:11 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby muretti0114 » Tue Sep 29, 2020 7:42 pm

Dear Jim,

Thanks for your reply.

I had no idea to use MOT2002_0 as Digital Sensor, which is great!!
I will use both mode depending on target use cases.
As for its behavior as a Voltage Ratio sensor, I thought it quite similar to
the previous 1111_0 sensor.

Thank you very much.

jimd
Phidgetsian
Posts: 9
Joined: Mon Sep 21, 2020 7:49 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jimd » Wed Sep 30, 2020 7:50 am

@muretti0114

Glad it helped!

As @jdecoux said, if you open it as a 'VoltageInput' then you can set your own threshold, whereas 'DigitalInput' seems to have a fixed threshold of approx. 3.0.

@jdecoux

Many thanks for the info re. the Saturation error. Yes, MOT2002_0 does seem to lack the normal quality of documentation so far.

Jim

jdecoux
Labview Developer
Posts: 124
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby jdecoux » Wed Sep 30, 2020 10:23 am

I will caution against using this sensor with the DigitalInput API, in that the voltage from the sensor can swing up or down, while the DigitalInput will only detect in one direction.

muretti0114
Fresh meat
Posts: 3
Joined: Mon Sep 28, 2020 3:11 am
Contact:

Re: Correct Sensor Type for MOT2002_0 ?

Postby muretti0114 » Wed Sep 30, 2020 7:56 pm

@jimd

Thanks for your great help! :D

@jdecoux

Yes, I will choose either Digital or Voltage mode carefully, depending on the target use case. I look forward to seeing the detailed document, but I am not in a hurry so please take time :)


Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests