PhidgetRFID Error

Supporting Java SE version 7 and up
wolcy97
Fresh meat
Posts: 2
Joined: Wed Apr 29, 2020 6:23 pm
Contact:

PhidgetRFID Error

Postby wolcy97 » Sun May 03, 2020 10:56 am

Hello there,

We want to use Phidget RFID (1024_0) device by connecting it to an android device via usb.

For this reason, we called api methods as in the examples at
https://www.phidgets.com/?view=api

Before doing this process, we added "Phidget22usb.jar" references to our project as at
https://www.phidgets.com/docs/Language_ ... orkarounds

We are developing in the flutter environment.
However, adjustments have been made on the android studio side for the operations that need to be done on the android.

When we connect to android device in debug mode, usb accesses and all required parameters can be read from the api. However, when we create the apk as a release and install it on the android device, we get an error as follows.

When opening the application (access to "PhidgetApi" is required at application launch), we get the error "unfortunately has stopped app".

when we investigated where the error originated, we found that it was caused by the "rfid = RFID ()" line you will see in the code line below.

I share the sample project code in the appendix.
You can also find the Manifest.xml file.

Due to this error, we were unable to make the devices available.

I would like your support.
Attachments
PhidgetRFID_Error (1).zip
(4 KiB) Downloaded 198 times

Return to “Java”

Who is online

Users browsing this forum: No registered users and 2 guests