SBC2 Firmware Upgrade Issue

Technical Discussions on any InterfaceKits
jason120679
Fresh meat
Posts: 3
Joined: Thu Jan 28, 2016 2:00 pm
Contact:

SBC2 Firmware Upgrade Issue

Postby jason120679 » Wed Feb 03, 2016 5:30 pm

My team developed a Phidgets based robotic control system 4 or 5 years ago. We had everything working very well. I have recently tried to set up an old SBC2 with a fresh install for another system. When I try to use the web interface to install gcc I get the output from the package manager posted at the end of this message.

Refreshing...

Get:1 http://www.phidgets.com squeeze Release.gpg [490 B]
Ign http://www.phidgets.com/debian/ squeeze/main Translation-en
Get:2 http://www.phidgets.com squeeze Release [1601 B]
Get:3 http://ftp.us.debian.org squeeze Release.gpg [1655 B]
Ign http://ftp.us.debian.org/debian/ squeeze/contrib Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/main Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/non-free Translation-en
Get:4 http://www.phidgets.com squeeze/main Sources [2184 B]
Get:5 http://ftp.us.debian.org squeeze Release [96.0 kB]
Get:6 http://www.phidgets.com squeeze/main armel Packages [4683 B]
Ign http://www.emdebian.org squeeze Release.gpg
Ign http://www.emdebian.org/grip/ squeeze/dev Translation-en
Ign http://www.emdebian.org/grip/ squeeze/doc Translation-en
Ign http://www.emdebian.org/grip/ squeeze/java Translation-en
Ign http://www.emdebian.org/grip/ squeeze/main Translation-en
Ign http://www.emdebian.org squeeze Release
Err http://www.emdebian.org squeeze/main armel Packages
404 Not Found
Get:7 http://ftp.us.debian.org squeeze/main armel Packages [8215 kB]
Err http://www.emdebian.org squeeze/dev armel Packages
404 Not Found
Err http://www.emdebian.org squeeze/java armel Packages
404 Not Found
Err http://www.emdebian.org squeeze/doc armel Packages
404 Not Found
Get:8 http://ftp.us.debian.org squeeze/contrib armel Packages [52.2 kB]
Get:9 http://ftp.us.debian.org squeeze/non-free armel Packages [98.5 kB]
Fetched 8472 kB in 48s (176 kB/s)

Installing...

Reading package lists...
Building dependency tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: gcc (>= 4:4.4.3) but it is not going to be installed
Depends: g++ (>= 4:4.4.3) but it is not going to be installed

Done.


I read in another post that http://www.emdebian.org was discontinued and that we should upgrade to the full debian 7 firmware.

My Problem - I have downloaded the new SBC2 firmware phidget2_1.1.1.20150804.bin to a thumbdrive and plugged it into a USB port on the SBC2. Then I went to system->backup&restore and clicked GO to enter recover mode. After it roboots I am expecting to be able to upgrade the system but it says

"No suitable upgrade files were found. Please attach as USB drive containing suppored upgrade file(s) and reload this page. Supported files are UBI Images (system_ubi.img), Kernel images (uImage) and Upgrade packages containing both (phidgetsbc2-*.bin). Upgrades must be done from a USB drive. See product manual for more information."

Am I missing something?

Jason

jason120679
Fresh meat
Posts: 3
Joined: Thu Jan 28, 2016 2:00 pm
Contact:

Re: SBC2 Firmware Upgrade Issue

Postby jason120679 » Thu Feb 04, 2016 4:15 pm

I found the solution in another thread. Sorry for the re-post.

The firmware I downloaded online includes an underscore '_' in the title.

phidget2_1.1.1.20150804.bin

If you change it to a hyphen '-' it works.

phidget2-1.1.1.20150804.bin

Jason

User avatar
Patrick
Lead Developer
Posts: 3067
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC2 Firmware Upgrade Issue

Postby Patrick » Thu Feb 04, 2016 4:16 pm

You need to rename the file from phidget2_1.1.1.20150804.bin to phidget2-1.1.1.20150804.bin.

This is related to a stupid bug on the website.

-Patrick

mz06
Fresh meat
Posts: 1
Joined: Sun Oct 16, 2016 3:59 am
Contact:

Re: SBC2 Firmware Upgrade Issue

Postby mz06 » Sun Oct 16, 2016 4:53 am

I have lost the ability to compile C programs with gcc.

I have an SBC2 that has been working fine but I needed to do an update to be compatible with the latest version of the Phidgets control panel. In order to do the update, I had to do a factory reset and then do this firmware upgrade (along with the name change).
File Permissions: rwxr-xr-x, Owner: root, Group: root, Time: Mon Oct 10 15:39:12 2016
phidgetsbc2-1.1.1.20150804.bin

That went OK but now I do not have gcc. I have updated all the packages although I see some errors and here is what I get when I click the install "C/C++ Development Tools/Headers".

Refreshing...

Hit http://www.phidgets.com squeeze Release.gpg
Ign http://www.phidgets.com/debian/ squeeze/main Translation-en
Ign http://ftp.us.debian.org squeeze Release.gpg
Ign http://ftp.us.debian.org/debian/ squeeze/contrib Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/main Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/non-free Translation-en
Hit http://www.phidgets.com squeeze Release
Ign http://ftp.us.debian.org squeeze Release
Ign http://www.emdebian.org squeeze Release.gpg
Ign http://www.emdebian.org/grip/ squeeze/dev Translation-en
Ign http://www.emdebian.org/grip/ squeeze/doc Translation-en
Err http://ftp.us.debian.org squeeze/main armel Packages
404 Not Found [IP: 128.61.240.89 80]
Err http://ftp.us.debian.org squeeze/contrib armel Packages
404 Not Found [IP: 128.61.240.89 80]
Err http://ftp.us.debian.org squeeze/non-free armel Packages
404 Not Found [IP: 128.61.240.89 80]
Ign http://www.emdebian.org/grip/ squeeze/java Translation-en
Ign http://www.emdebian.org/grip/ squeeze/main Translation-en
Hit http://www.phidgets.com squeeze/main Sources
Ign http://www.emdebian.org squeeze Release
Hit http://www.phidgets.com squeeze/main armel Packages
Err http://www.emdebian.org squeeze/main armel Packages
404 Not Found
Err http://www.emdebian.org squeeze/dev armel Packages
404 Not Found
Err http://www.emdebian.org squeeze/java armel Packages
404 Not Found
Err http://www.emdebian.org squeeze/doc armel Packages
404 Not Found

Installing...

Reading package lists...
Building dependency tree...
Reading state information...

Done.

User avatar
Patrick
Lead Developer
Posts: 3067
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC2 Firmware Upgrade Issue

Postby Patrick » Mon Oct 31, 2016 11:03 am

It looks like something went wrong when you upgraded to version 1.1.1 - are you sure this worked? You did this by putting the .bin on a USB drive and flashing it from the recovery system?

Something you may want to try is flashing to version 1.1.1, and then instead of pushing the reset button, just unplug and replug the power. I suspect your SBC may have reflashed itself to the factory settings during reboot.

I know that it didn't work for you because your apt messages are Debian 6 (squeeze), but the 1.1.1 release is Debian 7 (wheezy).

-Patrick


Return to “InterfaceKits”

Who is online

Users browsing this forum: No registered users and 1 guest