Issues Using ROS Launch file for Phidgets High Speed Encoder

Supporting 2.6 and up
antbre
Fresh meat
Posts: 2
Joined: Thu Sep 10, 2020 11:03 am
Contact:

Issues Using ROS Launch file for Phidgets High Speed Encoder

Postby antbre » Thu Sep 10, 2020 11:10 am

Hi,

when trying to use the launch file provided on the github page an error occurs:

Code: Select all

[ INFO] [1599756804.207999555]: Loading nodelet /PhidgetsHighSpeedEncoderNodelet of type phidgets_high_speed_encoder/PhidgetsHighSpeedEncoderNodelet to manager enc_manager with the following remappings:
[ INFO] [1599756804.210156649]: waitForService: Service [/enc_manager/load_nodelet] has not been advertised, waiting...
[ INFO] [1599756804.228704859]: Initializing nodelet with 4 worker threads.
[ INFO] [1599756804.231184823]: waitForService: Service [/enc_manager/load_nodelet] is now available.
[ INFO] [1599756804.235599941]: Initializing Phidgets High Speed Encoder Nodelet
[ INFO] [1599756804.235702657]: Starting Phidgets Encoders
[ INFO] [1599756804.238131994]: Connecting to Phidgets Encoders serial 484748, hub port 0 ...
[ INFO] [1599756804.767002463]: Connected 1 encoders
[ INFO] [1599756804.768207356]: Channel 0: 'joint0_tick2rad'='joint0'
[ INFO] [1599756804.768247420]: Publishing decimated speed of channel 0 to topic: joint_states_ch0_decim_speed
[ERROR] [1599756804.769084135]: Encoders: Failed to set enabled for Encoder channel 0: Operation Not Supported
[FATAL] [1599756805.269454404]: Failed to load nodelet '/PhidgetsHighSpeedEncoderNodelet` of type `phidgets_high_speed_encoder/PhidgetsHighSpeedEncoderNodelet` to manager `enc_manager'
[PhidgetsHighSpeedEncoderNodelet-2] process has died [pid 80497, exit code 255, cmd /opt/ros/noetic/lib/nodelet/nodelet load phidgets_high_speed_encoder/PhidgetsHighSpeedEncoderNodelet enc_manager __name:=PhidgetsHighSpeedEncoderNodelet __log:=/home/antbre/.ros/log/2a0a59d4-f381-11ea-a35d-c329d3a20397/PhidgetsHighSpeedEncoderNodelet-2.log].
log file: /home/antbre/.ros/log/2a0a59d4-f381-11ea-a35d-c329d3a20397/PhidgetsHighSpeedEncoderNodelet-2*.log


In the launch file I have only added the serial number as a parameter and it seems to start launching the correct things... to make sure I've installed everything correctly I even tried the launch file for the Phidgets Spatial IMUs and these launched without any problems.

I am using ros noetic on a Ubuntu 20.04 based distribution and a Phidget HighSpeed Encoder 1057-2.

Am I overlooking something in the launch file?

Best regards,

Anton

antbre
Fresh meat
Posts: 2
Joined: Thu Sep 10, 2020 11:03 am
Contact:

Re: Issues Using ROS Launch file for Phidgets High Speed Encoder

Postby antbre » Fri Sep 11, 2020 7:21 am

I think I know why the launch file fails however, I'm not sure how to get around the problem.

It seems that the launch file calls the function

Code: Select all

setEnable
. The problem is that the channel 0 on the 1057 2 is always enabled. Therefore a

Code: Select all

Operation Not Supported
error is thrown...

Anybody got an idea on how to get around that?

User avatar
mparadis
Site Admin
Posts: 733
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Issues Using ROS Launch file for Phidgets High Speed Encoder

Postby mparadis » Fri Sep 11, 2020 8:01 am

I don't have experience with ROS but it seems like you're going to need to edit the source code to remove the setEnabled call. This module was probably designed specifically for the 1047.

Better yet, if there was proper error handling added, it could just ignore the "Not Supported" error instead of crashing.


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 3 guests