Install Phidgets22 Error

Supporting 10.7 and up
Haggis2018
Fresh meat
Posts: 2
Joined: Mon Jan 21, 2019 12:36 pm
Contact:

Install Phidgets22 Error

Postby Haggis2018 » Tue Jan 22, 2019 4:45 am

I am trying to install Phidgets22 onto a Mac mini running 10.6.7. I have downloaded the installer for older OS. When I double click the Phidgets.PKG I get the following error.

This operation couldn't be completed
(Com.apple.installer.pagecontroller error -1)
Couldn't open Phidgets.PKG

User avatar
Patrick
Lead Developer
Posts: 3098
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Install Phidgets22 Error

Postby Patrick » Thu Jan 24, 2019 1:26 pm

Can you try installing the previous version and let me know if it's working: https://www.phidgets.com/downloads/phid ... 190107.dmg

-Patrick

User avatar
Patrick
Lead Developer
Posts: 3098
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Install Phidgets22 Error

Postby Patrick » Mon Jan 28, 2019 1:59 pm

This is fixed for the next release.

-Patrick

mgmikeyg
Fresh meat
Posts: 1
Joined: Sun Mar 17, 2019 11:42 am
Contact:

Re: Install Phidgets22 Error

Postby mgmikeyg » Sun Mar 17, 2019 11:47 am

Hi,
Im trying to install v22 onto my MacBook but I am now being told that the libraries may need to be reinstalled?? I'm trying to connect to Artisan which is showing the following: Exception Phidget1048tempnontype object has no attribute 'getfirstmatchingPhidget@line39480' I've been having difficulty installing v22 anyway and was hoping the link above would resolve my difficulties only to be confronted with the current libraries issue!! Any ideas?
Thanks Mike

plbaojiemnez
Fresh meat
Posts: 1
Joined: Mon Mar 18, 2019 9:44 am
Contact:

Re: Install Phidgets22 Error

Postby plbaojiemnez » Mon Mar 18, 2019 9:48 am

mgmikeyg wrote:Hi,
Im trying to install v22 onto my MacBook but I am now being told that the libraries may need to be reinstalled?? I'm trying to connect to Artisan which is showing the following: Exception Phidget1048tempnontype object has no attribute 'getfirstmatchingPhidget@line39480' I've been having difficulty installing v22 anyway and was hoping the link above would resolve my difficulties only to be confronted with the current libraries issue!! Any ideas?
Thanks Mike


Im having the same issue when I open the Phidgets control panel.

Phidgets Driver Failure

"Kext load failed (Code: 4). You may need to reinstall the Phidgets libraries. If you still have issues, contact Phidgets."

Please help,

Pablo.

Kit
Fresh meat
Posts: 3
Joined: Fri Oct 04, 2019 5:58 am
Contact:

Re: Install Phidgets22 Error

Postby Kit » Fri Oct 04, 2019 7:26 am

Hi,

I'm having exactly the same issue, no matter what I try.

I think it may be an issue with the .kext file.

Please, any ideas?

Thanks
Kit


Return to “macOS”

Who is online

Users browsing this forum: wuhuilin11 and 5 guests