Strange Phidgets Spatial 1044 Connection Issue with Macbook

Supporting 10.7 and up
CRAZEERUSKEE
Phidgetsian
Posts: 5
Joined: Thu May 18, 2017 11:58 am
Contact:

Strange Phidgets Spatial 1044 Connection Issue with Macbook

Postby CRAZEERUSKEE » Thu May 18, 2017 1:15 pm

Hello,

This is my first post here, so hi!

More importantly, I'm getting a pretty strange issue connecting my Phidgets Spatial to my Mac. The test program in System Preferences works perfectly, but running example programs like Accelerometer-simple.c from Terminal gives me a connection timeout every time.

I've tried unplugging and plugging it in while running the program as well as just running it with it already plugged in. My cable is pretty short so I don't think that's an issue.

Stranger still, the accelerometer program works fine on my Raspberry Pi.

I must say that I really love this IMU as well as how much effort was put into the documentation, but this issue has me totally stumped. Any help would be greatly appreciated. :)

CRAZEERUSKEE
Phidgetsian
Posts: 5
Joined: Thu May 18, 2017 11:58 am
Contact:

Re: Strange Phidgets Spatial 1044 Connection Issue with Macb

Postby CRAZEERUSKEE » Thu May 18, 2017 1:32 pm

Ok it seems like the Spatial-simple.c example works fine from Terminal.

However this leads into a slightly different issue. I copied over the Spatial-simple.c code into a qt creator and it says that it can't find the phidgets21.h file. Looking around my files, I can't find it either. I also can't find the related library files at all. In System/Frameworks and other such folders, there's nothing having to do with phidgets. However the example code and the system preferences test program works so the library was definitely installed somewhere....right? I'm very confused.

User avatar
Patrick
Lead Developer
Posts: 3089
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Strange Phidgets Spatial 1044 Connection Issue with Macb

Postby Patrick » Thu May 18, 2017 2:35 pm

Framework is install in /Library/Frameworks
phidget21.h is in /Library/Frameworks/Phidget21.framework/Headers

-Patrick

CRAZEERUSKEE
Phidgetsian
Posts: 5
Joined: Thu May 18, 2017 11:58 am
Contact:

Re: Strange Phidgets Spatial 1044 Connection Issue with Macb

Postby CRAZEERUSKEE » Thu May 18, 2017 2:40 pm

Thanks! That seems to work, but now it's giving two more errors:

symbol(s) not found for architecture x86_64

linker command failed with exit code 1 (use -v to see invocation)

I have no idea what either of those mean or why they are happening.


Return to “macOS”

Who is online

Users browsing this forum: No registered users and 1 guest