Search Results

by ProtonTim
Wed May 15, 2024 2:10 pm
Forum: All Other Phidgets
Topic: OUT1001_0 Isolation
Replies: 1
Views: 2207

OUT1001_0 Isolation

The OUT1001_0 is noted as isolated, but I do not see the isolation voltage level listed. What is the isolation voltage level of the OUT1001_0?
by ProtonTim
Wed Mar 20, 2024 2:56 pm
Forum: General
Topic: Phidget 1017_2 disconnecting from VINT hub
Replies: 8
Views: 9323

Re: Phidget 1017_2 disconnecting from VINT hub

Patrick,

I added your "fix" where I continuously (ever ~1/2 second) reset the failsafe and I have not seen the issue since then. So anecdotally that seems to have fixed the issue.

The hubs are connected to a powered usb hub board.

Tim
by ProtonTim
Tue Mar 12, 2024 9:15 am
Forum: General
Topic: Phidget 1017_2 disconnecting from VINT hub
Replies: 8
Views: 9323

Re: Phidget 1017_2 disconnecting from VINT hub

Can you give me an estimate of when that might be completed?
by ProtonTim
Fri Mar 08, 2024 1:44 pm
Forum: General
Topic: Phidget 1017_2 disconnecting from VINT hub
Replies: 8
Views: 9323

Re: Phidget 1017_2 disconnecting from VINT hub

Attached is a log file. As you can see the 1017 re-enumerates several times before failing. If I run the code again it will reattach and run without issue (for a while). No power cycling is needed.
phidgetlog.log
(7.73 KiB) Downloaded 232 times
by ProtonTim
Fri Mar 08, 2024 9:24 am
Forum: General
Topic: Phidget 1017_2 disconnecting from VINT hub
Replies: 8
Views: 9323

Phidget 1017_2 disconnecting from VINT hub

I have a 1017_2 connected to a VINT hub through about 6" of cable. It attaches fine, and runs fine at the start, but eventually experiences a 0x34 error indicating that the device is not attached. The relays are switching a resistive load (metal film resistors) for balancing battery cells so th...
by ProtonTim
Sat Jan 27, 2024 3:41 pm
Forum: General
Topic: VCP1000 Performance
Replies: 0
Views: 10414

VCP1000 Performance

The 20 bit ADC (VCP1000_0) states that is has a Measurement Error Max 0.01%. Does that mean the reported measurements can be off by as much as 0.0001 * 80V = 8mV even though it has 77μV resolution? Or is that error only at full scale? More specifically, my application involves measuring differential...
by ProtonTim
Thu Jan 25, 2024 2:35 pm
Forum: General
Topic: VCP1001 Resolution
Replies: 2
Views: 8717

Re: VCP1001 Resolution

Thank you for the clarification. The 20 bit ADC (VCP1000_0) states that is has a Measurement Error Max 0.01%. Does that mean the reported measurements can be off by as much as 0.0001 * 80V = 8mV even though it has 77μV resolution? Would this error only occur at this magnitude at full scale? If I wer...
by ProtonTim
Wed Jan 24, 2024 10:41 am
Forum: General
Topic: VCP1001 Resolution
Replies: 2
Views: 8717

VCP1001 Resolution

The VCP1001_0 says 10bits on the case, but in the specs it says it has 200uV resolution across a +5/-5 range. 10V/2^10 = 9.7mV, what am I missing?
by ProtonTim
Wed Nov 22, 2023 12:55 pm
Forum: General
Topic: SBC4 with touch screen
Replies: 0
Views: 137528

SBC4 with touch screen

Is it possible to run the SBC4 with a touch screen? I would like to run a Python/tkinter script on it which uses a touch screen.
by ProtonTim
Sat Oct 29, 2022 12:34 pm
Forum: C#.NET
Topic: Cross threading
Replies: 2
Views: 23796

Re: Cross threading

Thank you very much. The following code seems to do the trick. public void Accelerometer0_AccelerationChange(object sender, Phidget22.Events.AccelerometerAccelerationChangeEventArgs e) { Invoke((MethodInvoker)delegate { // Running on the UI thread AccelX.Text = e.Acceleration[0].ToString(); }); }