7013 Error with 0/0/4 [Resolved]

Supporting Labview 2012 and up
Fresh meat
Posts: 1
Joined: Fri Sep 12, 2014 2:39 pm

7013 Error with 0/0/4 [Resolved]

Postby RLucas » Fri Sep 12, 2014 3:03 pm


I'm trying to run the LED Example vi on the site using a 0/0/4 phidget interface (1014_1), and I keep getting a 7013 error. The phidget control panel can see the 0/0/4 (and can toggle the led on/off manually), but labview's having issues.

Specifically, it's hanging up at the Wait_Attach subvi - it'll go to the library call, and then just hang, waiting to find the phidget until it times out. (It crashes if I don't give it a time-out limit).

I've tried running it as is, I've tried hard-coding in the phidget21.dll it needs to reference, and I've also tried having it call a blank dll first, and then calling the phidget21.dll. I don't have the control panel running (or anything else referencing the phidget) when I'm doing any of the labview stuff, and I've repeatedly tried closing out labview and unplugging the phidget just in case labview thinks something (or itself) was talking to it. I've even shut my computer down a few times just to make sure nothing's trying to talk to it before I try and get labview to talk to it. I've tried having it call through winapi and through c, and I've tried having it run in any thread and in UI threads only.

If I try to bypass the Wait_Attach, it says there's nothing attached (error 7005, which is to be expected). Before the wait_attach, no errors (including going through the open step just before w_a).

This is all using win7 sp1, labview eval version 2014, and all the drivers and everything for the phidget are fully updated (I just downloaded all this stuff today).

If I couldn't get the manual led on/off toggle to work, I'd say it might be broken - we just found it in a cabinet at work the other day, so who knows that it's been through - but the the control panel works, so that makes me think that's not the case.

Any advice to make this thing work?

Thanks in advance,

And as always, I managed to figure it out about 40 minutes after the question - I should have been using the examples/interfacekit, not just examples. The ones in interfacekit worked beautifully. Never mind!

Return to “Labview”

Who is online

Users browsing this forum: No registered users and 1 guest