Question about setting Data rate of 1019_1 IO board?

C, C++, and Visual C++
kuoshih
Fresh meat
Posts: 2
Joined: Mon Sep 30, 2013 12:51 pm
Contact:

Question about setting Data rate of 1019_1 IO board?

Postby kuoshih » Mon Sep 30, 2013 12:58 pm

Dear all,

Currently I use 1019_1 IO board to get the analog data from my sensor. The sample code I use is "InterfaceKit". However, the mode of this sample is trigger mode. Could I set the Data rate as 50 msec using this sample code? or I only can modify the "Spatital" becuase I found the function "CPhidgetSpatial_setDataRate"?

Thank you!

User avatar
mparadis
Site Admin
Posts: 703
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Question about setting Data rate of 1019_1 IO board?

Postby mparadis » Mon Sep 30, 2013 1:55 pm

You can change the data rate by setting the change trigger to 0 and then using "CPhidgetInterfaceKit_setDataRate". Note that the data rate (in msec) must be 1,2,4, or a multiple of 8 (so you would want 48 or 56).

kuoshih
Fresh meat
Posts: 2
Joined: Mon Sep 30, 2013 12:51 pm
Contact:

Re: Question about setting Data rate of 1019_1 IO board?

Postby kuoshih » Tue Oct 01, 2013 8:57 am

Thank you! I did it.


mparadis wrote:You can change the data rate by setting the change trigger to 0 and then using "CPhidgetInterfaceKit_setDataRate". Note that the data rate (in msec) must be 1,2,4, or a multiple of 8 (so you would want 48 or 56).


Return to “C/C++”

Who is online

Users browsing this forum: No registered users and 1 guest