libusb issues- Ubuntu **solved**

Supporting 2.6 and up
pfarrell
Fresh meat
Posts: 1
Joined: Thu May 03, 2012 11:05 am
Contact:

libusb issues- Ubuntu **solved**

Postby pfarrell » Thu May 03, 2012 11:22 am

my build of phidget21 errors out at ./configure because libusb cannot be found. yet I can see that libusb (and libusb-dev, etc) is installed.
I notice that /usr/lib/pkgconfig does not include a *.pc file in either of my Ubuntu distributions.
Any suggestions?
thanks!

Code: Select all

-desktop:~$ sudo apt-cache search  libusb
libusb++-0.1-4c2 - userspace C++ USB programming library
libusb++-dev - userspace C++ USB programming library development files
libusb-0.1-4 - userspace USB programming library
libusb-dev - userspace USB programming library development files
libdjconsole-data - Hercules DJ Console access library - data files
libdjconsole-dev - Hercules DJ Console access library - development headers
libdjconsole0 - Hercules DJ Console access library
libftdi1 - Library to control and program the FTDI USB controller
libhid-dev - userspace USB HID development files
libhid0 - userspace USB HID access library
libusb-1.0-0 - userspace USB programming library
libusb-1.0-0-dev - userspace USB programming library development files
libusbprog-dev - Development files for libusbprog
libusbprog0 - Library for programming the USBprog hardware
python-hid - Python wrapper for USB HID access library
spectools - Utilities for using the Wi-Spy USB spectrum analyzer hardware



************************************
my bad- libusb-dev was not properly installed...

I tested on two separate versions of Ubuntu- 9.04 (no longer supported) and 11.04. and I had problems on both. ???

for 9.04, a distribution that Ubuntu no longer supports (i.e. upgrades) I went to the Ubuntu website and downloaded the debian package:

http://packages.ubuntu.com/lucid/libusb-0.1-4
(I needed to update libusb to meet the newer requirements for libusb-dev)
and then:
http://packages.ubuntu.com/lucid/libusb-dev
(note that I chose "Lucid" even though my version was the older "Jaunty")

On my newer system (Ubuntu 11.04) I was able to use apt-get:

Code: Select all

myDesktop$  sudo apt-get install libusb

(this will install or upgrade, as needed)
and then:

Code: Select all

myDesktop$  sudo apt-get install libusb-dev


This should have worked for me the first time- but I ignored an error from apt-get indicating a network failure!
:?

Return to “Linux”

Who is online

Users browsing this forum: No registered users and 0 guests