phidgets2.1 - web service - crashing bonjour - Mac Mini Lion

Supporting 10.7 and up
timosea
Phidgetsian
Posts: 5
Joined: Tue Jul 17, 2007 5:06 am

phidgets2.1 - web service - crashing bonjour - Mac Mini Lion

Postby timosea » Fri Feb 24, 2012 7:15 am

This very strange I just moved a relatively simple RFID project from my Macbook Pro (Lion 10.7.3) to a new Mac Mini (Lion 10.7.3) supplied by my client; this new machine just has my AS3 Phidgets RFID app an all the associated media installed, as it is purely for use for this project.

Initially everything runs super smoothly; install and start the Phidgets 2.1 web service; copy Flash App (created in CS5.5) all the latest AS3 phidgets library and the associated media files - at this point everything runs absolutely fine!

Then I add the Flash app to the start up items (mac sys prefs), I do this for all my installations to allow the client a simple on/off option just in case of crashes and for daily easy of use. I then restart mac to test, at this point the Phidgets RFID device fails to appear in bonjour tab on the phidgets sys pref, although the device is attached in sys prefs; when double clicked in general tab, the LED and Antenna enable fine. I assume that it not visible as phidget web service attached device in the bonjour tab then my Flash app will never be able to connect?

Numerous restarts later, removing the Flash app from start up items, disabling the automatic start option and manually restarting the web service also fails after even more restarts. I have used the same RFID board and procedure and files on MacBook Pro and it still all works fine, I also tried different RFID boards on the Mac Mini; those also fail; NOTE phidget web service attached device is still missing in Bonjour tab in the sys prefs on Mac Mini.

I assuming something is proper crashing Bonjour or the Phidget web service on the Mac Mini; as the mac mini is clean and just used for this project I did cmd+R reinstall of OSX and tested again, 2 hours later…

.. I have the same situation; very strange that this happens only on the new mac mini and not my Macbook pro; both machine are running the same version of Lion and very similar specs.

I have attached the crash report from my mac console, if that helps?

Your help this issue would be very much appreciated.

Cheers, Tim
Attachments
phidgetwebservice21_crash.txt
(30.36 KiB) Downloaded 392 times

timosea
Phidgetsian
Posts: 5
Joined: Tue Jul 17, 2007 5:06 am

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby timosea » Fri Feb 24, 2012 7:58 am

Update: If I delete /Library/Frameworks/Phidget21 and the phidgets from the system preference, then reinstall phidget_2.1.8.20120216.dmg and restart the mac mini. The first time phidget web service attached device magically appear in Bonjour tab, and my Flash app worked fine and I could detach the RFID reader the app would find it; close and open the app and it works fine. Great, so I make zero changes; restart the mac mini, now back to same issue with the 'phidget web service attached device' is now once again missing in Bonjour tab, resulting in my Flash app failing to connect to the phidget service. So tried the manually deleting the /Library/Frameworks/Phidget21 framework again and reinstalling the phidget_2.1.8.20120216.dmg trick to see if worked again; unfortunately this now also fails after numerous restarts.

This very frustrating issue; I spent longer trying to work this out than did coding the original app. I never experienced this before, Phidgets just normally works; not really sure where to look for a solution?

timosea
Phidgetsian
Posts: 5
Joined: Tue Jul 17, 2007 5:06 am

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby timosea » Fri Feb 24, 2012 9:40 am

THIS PROBLEM WITH THE LATEST BUILD OF Phidget_2.1.8.200216.dmg !!!

It took me a while to realise that although the version numbers of the phidget services don't appear to change I was actually using deferent builds of the phidgets web services on my dev machine and my clients machine; the new client machine which was have all the horrible issues was using the latest build of the web services!

I'm now using an old build of 2.1.8 , from May 20 2011 according to the install screen and Nov 21 2011 from the system prefs screen which I had on my dev machine; this build on the new mac mini works absolutely fine!

SO THINK THIS AN ISSUE WITH THE LEAST BUILD that effects LION 10.7.3, the webservice works fine after initial install, but FAILS to work after a restart!

Reverting to an older build of Phidget_2.1.8 , from May 20 2011 has resolved all my issues.

User avatar
Patrick
Lead Developer
Posts: 3052
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby Patrick » Fri Feb 24, 2012 10:30 am

Would you mind trying version 2.1.8.20111220 and see if there are issues? There were some changes to RFID code after this release.

You can get older releases here: http://www.phidgets.com/old_drivers.php

I'll look into this issue and see if I can re-produce.

-Patrick

timosea
Phidgetsian
Posts: 5
Joined: Tue Jul 17, 2007 5:06 am

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby timosea » Fri Feb 24, 2012 10:38 am

Sure, will try on Monday and report back.

timosea
Phidgetsian
Posts: 5
Joined: Tue Jul 17, 2007 5:06 am

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby timosea » Mon Feb 27, 2012 5:14 am

Sorry Patrick, but unfortunately I can replicate the issue with version 2.1.8.20111220, so had to revert back to version 2.1.8.20111121; which appears to work like clockwork after every restart on both my dev and clients Macs.

When I tried 2.1.8.20111220 as you requested, I deleted /Library/Frameworks/Phidget21 framework and phidgets from the system prefs; I also had turn off the firewall settings on the mac mini which was initially causing a problem. Then with firewall off the web service started fine, and everything worked; BUT only after the initial - post install restart; all other restarts resulted with the web service failing to start at all (with firewall turned off).

Once I reverted back to version 2.1.8.20111121 the issue appears to be resolved, I have restarted the mac mini numerous times and every just works normally on every single restart as opposed to just in the initial post install restart on the newer builds.

Kruemelmonster
Fresh meat
Posts: 1
Joined: Tue Mar 20, 2012 7:22 am
Contact:

Re: phidgets2.1 - web service - crashing bonjour - Mac Mini

Postby Kruemelmonster » Tue Mar 20, 2012 7:36 am

We experienced a similar problem. (Mac OS 10.6.8 / 10.7.3) Though the web service keeps running using an older release, we're having now problems with the AS-Library. Is there a page, where we can download older versions of the AS-Library too?

Regards!


Return to “macOS”

Who is online

Users browsing this forum: No registered users and 0 guests