Problem with 0/16/16 USB Drivers

Technical Discussions on any InterfaceKits

Problem with 0/16/16 USB Drivers

Postby agarden » Mon Oct 13, 2008 11:00 pm

Just received my 0/16/16, wired it up and plugged it into my Vista laptop. Vista claims no driver exist for this device.

I've installed the Phidgets software and the examples for Microsoft Robotics Studio... still no dice. What gives?

Thanks for the help!!


User avatar
Lead Developer
Posts: 3155
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada

Postby Patrick » Tue Oct 14, 2008 10:02 am

Phidgets use the Windows HID driver - are you using a special version of Vista? Do the Phidgets examples / control panel work?



HID Driver

Postby agarden » Tue Oct 14, 2008 10:24 am

I understand this is the case... For some odd reason Windows is unable to install the HID driver for this device. I have quite a few other HID compliant devices which seem to work correctly 100% of the time.

I thought perhaps there was something about Vista (as there usually is) I had to be aware of...

In any event, I don't see the device registered in the Phidgets control panel when I plug it in (likely as the HID driver won't register)...

Am I missing something obvious?

Site Admin
Posts: 263
Joined: Fri Dec 05, 2003 3:45 pm
Location: Canada

Postby fitchett » Tue Oct 14, 2008 10:36 am

If you have access to any other Windows computers, please give it a try. You don't have to install our libraries to see if the device installs successfully and matches against the proper drivers.



Will do...

Postby agarden » Tue Oct 14, 2008 10:48 am

Thanks Chester... I was just being lazy last night. I'll certainly give it a shot on another machine tonight.




Problem with MS HID Driver Install

Postby agarden » Tue Oct 14, 2008 8:02 pm

When I manually select Windows HID Driver I get the error in the following... What the heck??

"The driver installation file for this device is missing an entry. This may be because the INF was written for Windows 95 or later. Contact your hardware vendor."




Postby agarden » Tue Oct 14, 2008 9:41 pm

Okay... Seems like I solved the problem. When you install SP1 with Vista, the default HID drivers are no longer recognized by Vista itself. (??!)...

Anyway, here's how you solve this:

Go to System-->Control Panel-->Device Manager

Right click on the 0/16/16 which you should recognize as a USB device with a '!' on it.

Click on the "driver" tab and select the "update driver" button.

Pick the manual option to find the driver yourself and use the following path


Windows will warn you that this driver is unsigned but just ignore this and go for it.

Immediate success... thank you Bill Gates (sheesh)


Return to “InterfaceKits”

Who is online

Users browsing this forum: No registered users and 4 guests