User "user" missing on SBC 3

General PhidgetSBC Discussion.
wvreeven
Phidgetsian
Posts: 6
Joined: Tue Mar 22, 2016 9:15 am
Contact:

User "user" missing on SBC 3

Postby wvreeven » Wed Jul 20, 2016 12:55 pm

Hi,

Today my brand new SBC 3 and 3703_0 WIFI adapter arrived via courier :) I am a very experienced Debian user and administrator so I quickly set up the SBC and my DHCP and Bind9 servers so the SBC gets a fixed IP. I enabled the SSH server and tried to login as user "user" as per the instructions here

http://www.phidgets.com/docs/1073_User_Guide#SSH

Access denied. Hmm. OK so after trying a few times and then actually reading the rest of the User Guide, I was able to login as "root". There appears to be no user "user" in /etc/passwd and the /home directory is empty.

Is this how it is supposed to be? If yes, can you please update the documentation so future newbies to SBC don't fall in the same trap? Many thanks in advance and keep up the otherwise excellent work on Phidgets!


Cheers, Wouter

User avatar
Patrick
Lead Developer
Posts: 3091
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: User "user" missing on SBC 3

Postby Patrick » Thu Jul 21, 2016 3:10 pm

Hi,

You are correct - this is actually old documentation from the original SBC, which had a pre-created 'user' account because the root fs was mounted read-only. On 1073, we didn't create any extra account, but you can of course create one if needed.

I'll get the docs updated.

Thanks,
-Patrick


Return to “General”

Who is online

Users browsing this forum: No registered users and 0 guests