Problem with Phidget 1063

Comments & issues
marco63
Fresh meat
Posts: 3
Joined: Thu Jan 19, 2012 9:07 am
Contact:

Problem with Phidget 1063

Postby marco63 » Thu Jan 19, 2012 9:18 am

Hi,
I just bought a Phidget 1063 and a stepper motor 3300 and they work great. I have developped a motorized focuser for my telescope. But I have a problem related with the Human Interface Device because I have an other software that open the HID. So, when Phidget is working it has its own HID, so when i open the other software (which is the software that manage the ccd camera connected to my telescope) this camera sofwtare does not work. I have seen the following situation:

- Phidget on, camera software on but it does not connect the camera
- Phidget on and then Phidget off, however camera software does not connects
- Camera software on, Phidget on but it does not "see" the controller 1063.

I need both working simultaneously.

I hope somebody can help, and sorry for my bad english but I live in Italy.

Kind Regards,
Marco

User avatar
Patrick
Lead Developer
Posts: 2943
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Problem with Phidget 1063

Postby Patrick » Thu Jan 19, 2012 10:35 am

Can you specify the exact camera and it's software and the website where it can be downloaded?



-Patrick

marco63
Fresh meat
Posts: 3
Joined: Thu Jan 19, 2012 9:07 am
Contact:

Re: Problem with Phidget 1063

Postby marco63 » Thu Jan 19, 2012 1:54 pm

The camera is very old and the software is not available at the web site. In the past I bought it with a parallel serial cable connection and then after some years they sold to me the Serial to USB interface. By the way here you can find the USB 1.1 installer:

http://www.starlight-xpress.co.uk/serv05.htm

and here the camera software: Star_M9.USB.zip (mx9)

A good new is the following, just one ago I have made the followed steps in this order:

1) turn ON PC (Phidgets start when Windows start). The Phidgets usb cable was disconnected, and the camera usb cable was connected.
2) launched the camera software and connected succesfully the camera;
3) connected the Phidgest USB cable;
4) loaded the 1063 controller succesfully;
5) the camera was still connected and working perfectly.

In this way I can run with both sofwtares simultaneoulsy.

Now I shoud find an automatic way to connect and disconnect the usb cable, something that can work by my remote office pc connected wireless with the astronomical observatory where there is another pc managing everything but controlled by me with the remote office pc.

By the way the controller 1063 is fantastic :D and I am learning sone VB6 in order to write my personal software for remote-autofocusing !

THANKS,
Marco

marco63
Fresh meat
Posts: 3
Joined: Thu Jan 19, 2012 9:07 am
Contact:

Re: Problem with Phidget 1063

Postby marco63 » Mon Jan 23, 2012 2:04 am

Update: problem solved.

It is only important to turn on Phidget as last software and turn off as first software. That's it.

Regards,
Marco


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests