Problem installing jamvm

Supporting Java SE version 7 and up
robinh

Problem installing jamvm

Postby robinh » Mon Nov 07, 2011 8:57 pm

The manual says " ... First, install ‘libphidget21-java’ via ‘apt-get install’, or Install ‘Java Support’ via the ‘System: Packages’ web interface page."

So I just used the system option from the web page. I seem to get an error ... " ... Depends: default-jre-headless but it is not going to be installed". Also what about the other errors, what does "Read error - read (0: Success)" mean? Should I just try again?

The SBC is fresh out of the shipping box today so I have about 2 hours experience.

I need to run a Java program without any host ( other than to compile/debug/download code) so I need JamVM.

Questions:
1. Is this a problem?
2. If yes, how to fix it?

Thanks
robinh

Here is the full log:

Refreshing...

Get:1 http://www.phidgets.com squeeze Release.gpg [490 B]
Ign http://www.phidgets.com/debian/ squeeze/main Translation-en
Get:2 http://ftp.us.debian.org squeeze Release.gpg [1672 B]
Ign http://ftp.us.debian.org/debian/ squeeze/contrib Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/main Translation-en
Ign http://ftp.us.debian.org/debian/ squeeze/non-free Translation-en
Get:3 http://www.emdebian.org squeeze Release.gpg [198 B]
Ign http://www.emdebian.org/grip/ squeeze/dev Translation-en
Ign http://www.emdebian.org/grip/ squeeze/doc Translation-en
Get:4 http://www.phidgets.com squeeze Release [1591 B]
Get:5 http://ftp.us.debian.org squeeze Release [87.3 kB]
Ign http://www.emdebian.org/grip/ squeeze/java Translation-en
Ign http://www.emdebian.org/grip/ squeeze/main Translation-en
Get:6 http://www.emdebian.org squeeze Release [28.8 kB]
Get:7 http://www.phidgets.com squeeze/main Sources [2118 B]
Get:8 http://www.phidgets.com squeeze/main armel Packages [2381 B]
Get:9 http://www.emdebian.org squeeze/main armel Packages [550 kB]
Get:10 http://ftp.us.debian.org squeeze/main armel Packages [8439 kB]
Get:11 http://www.emdebian.org squeeze/dev armel Packages [173 kB]
Err http://www.emdebian.org squeeze/main armel Packages
Read error - read (0: Success)
Get:12 http://www.emdebian.org squeeze/java armel Packages [9803 B]
Get:13 http://www.emdebian.org squeeze/doc armel Packages [6973 B]
Get:14 http://ftp.us.debian.org squeeze/contrib armel Packages [54.3 kB]
Get:15 http://ftp.us.debian.org squeeze/non-free armel Packages [101 kB]
Err http://ftp.us.debian.org squeeze/main armel Packages
Read error - read (0: Success)
Fetched 9459 kB in 1min 47s (87.6 kB/s)

Installing...

Reading package lists...
Building dependency tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libphidget21-java : Depends: default-jre-headless but it is not going to be installed

Done.

Return to “Java”

Who is online

Users browsing this forum: No registered users and 4 guests