8/8/8 Interface Kit on 1203 spurious sensor errors

Technical Discussions on any InterfaceKits
LKO
Phidgetsian
Posts: 5
Joined: Tue Jul 12, 2011 1:24 pm
Contact:

8/8/8 Interface Kit on 1203 spurious sensor errors

Postby LKO » Thu Dec 15, 2011 8:44 pm

I have a 1203 that I am using a couple of digital inputs on the interface kit. I have nothing else hooked up to the interface kit; no digital outputs or analog inputs. I'm noticing that I keep getting these spurious OVERRUN and PACKET_LOST errors, evidently having to do with the analog inputs. I'm ignoring these errors, as they seem to have no effect on my reading of digital inputs, but i do wonder why I am getting them at all. Should I be concerned?

I'm working in Java on Linux, using the phidgets21.jar; I believe it's the 2.1.7.20110203 version.

User avatar
burley
Human-Cyborg Relations
Posts: 441
Joined: Tue Sep 27, 2011 2:37 pm
Location: Calgary
Contact:

Re: 8/8/8 Interface Kit on 1203 spurious sensor errors

Postby burley » Fri Dec 16, 2011 8:09 am

Before anything else can you try updating to a more recent version of the drivers and library?

Drivers are available here: http://www.phidgets.com/drivers.php

.jar here: http://www.phidgets.com/downloads/libra ... 111121.zip
Brian Burley
403-282-7335 ext. 6003
support@phidgets.com

User avatar
Patrick
Lead Developer
Posts: 3091
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: 8/8/8 Interface Kit on 1203 spurious sensor errors

Postby Patrick » Fri Dec 16, 2011 10:47 am

Do you get them right after attach, or also long after attach?

You can generally ignore these messages.

-Patrick

LKO
Phidgetsian
Posts: 5
Joined: Tue Jul 12, 2011 1:24 pm
Contact:

Re: 8/8/8 Interface Kit on 1203 spurious sensor errors

Postby LKO » Sat Dec 17, 2011 12:49 am

Patrick, I get a burst of overruns immediately after attach, but the packet lost error only pops up occasionally within a couple minutes of attaching. I figured the analog inputs were sort of floating and picking up noise; glad to know I was ok to just ignore the errors for now.

Burley, good point; I am a bit behind on that. I'll update everything after I get some sleep (and back things up!).

LKO
Phidgetsian
Posts: 5
Joined: Tue Jul 12, 2011 1:24 pm
Contact:

Re: 8/8/8 Interface Kit on 1203 spurious sensor errors

Postby LKO » Wed Dec 21, 2011 8:05 pm

I've updated to the latest phidget java library with no ill effects; I still need to go back and see if it stopped any of those error messages. I'd just adjusted the code to ignore those errors.


Return to “InterfaceKits”

Who is online

Users browsing this forum: No registered users and 1 guest