Phidget library losing connection to WebService

Supporting iOS 8 and up
RainfrogDan
Phidgetsian
Posts: 6
Joined: Sat Feb 04, 2012 9:30 am
Contact:

Phidget library losing connection to WebService

Postby RainfrogDan » Thu Nov 06, 2014 1:14 pm

Hi

I've recently had a number of issues reported by various users of my iOS software, where connection to the WebService is randomly dropped. Seems to be mainly related to the SBC and later versions of iOS - particularly later incarnations of 7.x, and iOS 8.x. I cannot know exactly what's causing this on the user end, and have tried troubleshooting the usual network problems, but to no avail. I have also observed it myself in recent months with my hardware, so circumstantial evidence suggests it is not isolated.

My app's code is fairly tolerant of casual disconnects - it provides a 5 second buffer, so that if a reconnect is received within that window, operation will continue normally without alerting the user. These disconnects, therefore, are longer than 5 seconds and often require a software restart before connecting again.

Nothing has changed in my code since before I began receiving these reports and noticing the disconnects in my testing. I'm wondering what your official stance on iOS 8 compatibility is. Can you shed any light on known issues with later revisions of iOS?

Also wondering if support beyond ARM7 is still in the works?

Thanks for your help.
Danny

User avatar
Patrick
Lead Developer
Posts: 3078
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Phidget library losing connection to WebService

Postby Patrick » Thu Nov 06, 2014 2:44 pm

We have not extensively tested the webservice with iOS 8. The webservice does have known reliability issues, and this is why a replacement is in the works - release date to be determined.

Full support for all iOS processors is in the works - we are committed to continued iOS support.

-Patrick

RainfrogDan
Phidgetsian
Posts: 6
Joined: Sat Feb 04, 2012 9:30 am
Contact:

Re: Phidget library losing connection to WebService

Postby RainfrogDan » Fri Nov 07, 2014 8:45 am

Thanks Patrick

If I can be of any help field testing, just let me know. Sometimes I let probes run all day over heat on my testing bench. When I do roasts, I'm not in a position to see log entries, but could easily monitor activity in a testing environment and report back.

Danny


Return to “iOS”

Who is online

Users browsing this forum: No registered users and 1 guest