High noise level when sampling load cells over USB PhidgetBridge on SBC4 over USB

General PhidgetSBC Discussion.
fajitas23
Phidgetsian
Posts: 8
Joined: Sun Jun 10, 2018 5:33 am
Contact:

High noise level when sampling load cells over USB PhidgetBridge on SBC4 over USB

Postby fajitas23 » Tue Jun 19, 2018 4:43 am

Hi

I've been recording force profiles with four CZL635 micro load cells [1] and a USB PhidgetBridge 4-Input [2].

When I record the data on my Laptop (Lenovo Yoga 2017) using a python script, I get a very nice signal, with a noise level below 1N.

see Plot 1: https://ibb.co/cn1XkJ

However, plugging the USB cable into my SBC4 [3], running the same script and applying a similar force profile, results in a very noisy signal, with a noise level of 5N to 30 N.

see Plot 2: https://ibb.co/d5JpXy

Any idea what is going on here?

Is the supply voltage of the SBC4 USB port not constant enough (haven't been able to check)? It doesn't seem to be a problem with processing speed (see below).

Some more info:

1) The result is independent of which SBC USB port I use.
2) Processing power does not seem to be an issue. With the SBC4 I can log at about 3.5 kHz. With the laptop at about 8.5 kHz. The actual sampling frequency (change in read value) of the bridge is about 120 Hz in both cases (and as specified by Phidget).
3) The supply voltage to the SBC is sufficiently large.
4) The spike visible in plot 1 around 4 seconds is caused by an intended hit on the sensor.

Again, any help appreciated!

[1] https://www.phidgets.com/?tier=3&catid= ... prodid=226
[2] https://www.phidgets.com/?tier=3&catid= ... &prodid=35
[3] https://www.phidgets.com/?tier=3&catid= ... prodid=969

User avatar
Patrick
Lead Developer
Posts: 3078
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: High noise level when sampling load cells over USB PhidgetBridge on SBC4 over USB

Postby Patrick » Wed Jun 20, 2018 12:21 pm

Can you provide the python script? It looks like the gain is not being set properly on the SBC4.

-Patrick

fajitas23
Phidgetsian
Posts: 8
Joined: Sun Jun 10, 2018 5:33 am
Contact:

Re: High noise level when sampling load cells over USB PhidgetBridge on SBC4 over USB

Postby fajitas23 » Mon Jun 25, 2018 5:53 am

UPDATE:

I've identified the problem. It was indeed the power supply. After using a very accurate lab power supply (Korad KD3005D), I get a low noise level of ~0.05 N (SD) at 64x gain. The noise level when recording with the laptop is the same (0.048 N vs 0.046 N).

Update II:

With two 9V batteries in series I also get a low noise level. Have yet, to test how long the batteries last. At 18 V they draw about 250 mA reading six strain gauges.

Original Answer:

Hi Patrick

thanks for your help!

Like I said, the script is the exact same on both computers and so was the gain.

It was set to 7 (64x). I tried several lower gains but the result was the same. The noise level I tried were 1 (1x), 4 (8x,), 6 (32x).

I also tried running the SBC of a 9V block battery instead of the power supply. Not sure if it had an effect, but the signal was certainly much more noisy than when running the exact same script and comparable force profile on the laptop.

*puzzled*

Again, thanks for your help!

User avatar
Patrick
Lead Developer
Posts: 3078
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: High noise level when sampling load cells over USB PhidgetBridge on SBC4 over USB

Postby Patrick » Mon Jun 25, 2018 9:32 am

Can you send some photos of the malfunctioning setup, with closeups of the 2 boards? This could be a bad 1046, or a bad SBS3003, or maybe some sort of ground loop. The 1046 filters incoming power, so a noisy power supply should not introduce noise into the data.

-Patrick


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests