SBC3 loses USB devices

General PhidgetSBC Discussion.
berkinet
Phidget Mastermind
Posts: 150
Joined: Thu Sep 17, 2009 12:17 pm
Contact:

SBC3 loses USB devices

Postby berkinet » Wed May 23, 2018 9:00 am

    Firmware Version: PhidgetSBC3 - Version 1.0.1 - Built Thu Jan 8 16:10:58 MST 2015
    Kernel Version: Linux version 3.14.27 (patrick@debian) (gcc version 4.4.5 (Debian 4.4.5-8) ) #12 Thu Jan 8 15:16:14 MST 2015
    Distribution: Debian GNU/Linux 7
    Phidget Library: Phidget22 - Version 1.0.0 - Built May 8 2018 12:21:12
At seemingly random times (like 24 to 36 hours) my SBC3 simply loses all the attached USB devices.
Here is the result of a lsusb when everything is working

Code: Select all

Bus 001 Device 002: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 004: ID 06c2:0045 Phidgets Inc. (formerly GLAB) PhidgetInterface Kit 8-8-8
Bus 001 Device 005: ID 05a3:9230 ARC International
Note Device 005 is a webcam.
And, here is a lsusb when nothing is working

Code: Select all

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I suspect a memory leak in mjpg_streamer is the cause of the problem. But, I can't track it down. At this point all I really want to do is be able to remotely restart the USB system. That would allow be to build a simple watchdog script to monitor the USB bus and reset if after a failure.

The problem: I can't for the life of me find how do do this on Wheezy. I have found all kinds of scripts and code to reset the USB, but none of it seems to work in the SBC3. I guess I could just have the watchdog call reboot, but that seems a bit drastic. Ideas?

berkinet
Phidget Mastermind
Posts: 150
Joined: Thu Sep 17, 2009 12:17 pm
Contact:

Re: SBC3 loses USB devices

Postby berkinet » Fri May 25, 2018 1:26 am

The problem has become much worse. After ca failure during the night, the usb system will no longer load anything. I have removed all external usb devices and it still fails as...

Code: Select all

[    4.641357] usb 1-1: new full-speed USB device number 2 using ci_hdrc
[    4.861222] usb 1-1: device descriptor read/64, error -71
[    5.181333] usb 1-1: device descriptor read/64, error -71
[    5.411202] usb 1-1: new full-speed USB device number 3 using ci_hdrc
[    5.631333] usb 1-1: device descriptor read/64, error -71
[    5.951188] usb 1-1: device descriptor read/64, error -71
[    6.181277] usb 1-1: new full-speed USB device number 4 using ci_hdrc
[    6.661047] usb 1-1: device not accepting address 4, error -71
[    6.781269] usb 1-1: new full-speed USB device number 5 using ci_hdrc
[    7.260914] usb 1-1: device not accepting address 5, error -71
[    7.267842] hub 1-0:1.0: unable to enumerate USB device on port 1

User avatar
Patrick
Lead Developer
Posts: 3038
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC3 loses USB devices

Postby Patrick » Fri May 25, 2018 1:12 pm

Looks like a hardware failure. You could try a full factory reset to rule out software problems.

-Patrick


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest