Change to libs 2.2

General PhidgetSBC Discussion.
berkinet
Phidget Mastermind
Posts: 154
Joined: Thu Sep 17, 2009 12:17 pm
Contact:

Change to libs 2.2

Postby berkinet » Tue Aug 01, 2017 5:23 am

On my SBC3s web interface under System > Packages, I see the following packages available for upgrade:
    libphidget21-0
    libphidget22
    libphidget22extra
    phidget22admin
    phidgetconf
    phidgetsbcwebif
Since I still have software that uses the 2.1 API I need to continue to run the 2.1 libs. So, my questions are:
  1. Can I run both versions. I.e. Just Upgrade All Packages?
  2. If I can't run both 2.1 and 2.2 at the same time, can I upgrade the 2.1 libs to 99:2.1.8.20170727-1 using the web UI (and if so, how) or must I do the upgrade from the command line?
  3. Same question for other OSs (MacOS in particular).

Thanks.

User avatar
Patrick
Lead Developer
Posts: 3078
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Change to libs 2.2

Postby Patrick » Tue Aug 01, 2017 7:39 pm

Yes, you can run both - the libraries are completely separate from each other.

-Patrick

berkinet
Phidget Mastermind
Posts: 154
Joined: Thu Sep 17, 2009 12:17 pm
Contact:

Re: Change to libs 2.2

Postby berkinet » Wed Aug 02, 2017 2:50 am

Thanks for the clarification Patrick.


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests