SBC webservice stops

General PhidgetSBC Discussion.
danhoskin
Phidgetly
Posts: 45
Joined: Wed Jan 16, 2008 6:05 pm

SBC webservice stops

Postby danhoskin » Wed May 12, 2010 6:36 pm

I have a Win XP PC cat5'ed to an SBC with 3 Advanced Servo 8 Motor controllers attached to it. Every few hours for no reason that I can see, the webservice stops. What can cause this and how can I prevent it from happening? I read in a post here about hardware issues with connecting the SBC and Advanced Servo 4 motor controllers that required a hardware fix. Does this apply to the 8 motor units as well?
The project works great and I love the Phidgets SBC and controllers, but I have to come up with a way to stabilize the connection.

Any help would be greatly appreciated. (again ;)
Thanks

User avatar
Patrick
Lead Developer
Posts: 3046
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC webservice stops

Postby Patrick » Thu May 13, 2010 8:38 am

How do you know that the webservice is crashing - could it be that the Phidgets are disconnecting and the webservice is still running? Can you bring things back up by restarting the webservice in the web interface, or do you need to reboot the SBC?

-Patrick

danhoskin
Phidgetly
Posts: 45
Joined: Wed Jan 16, 2008 6:05 pm

Re: SBC webservice stops

Postby danhoskin » Thu May 13, 2010 10:11 am

In the Phidgets control panel the webservice status says 'stopped'. It will restart through the web interface without rebooting the SBC. It has been running for 5 hours so far today with no issues, but it would be nice to know that it is unlikely to happen again.

User avatar
Patrick
Lead Developer
Posts: 3046
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC webservice stops

Postby Patrick » Thu May 13, 2010 10:28 am

How are you using the webservice? ie are you connecting once and keeping the connection open, or are you connecting and disconnecting many times?

There is a memory leak in the webservice that only presents occasionally, and only on the SBC that we haven't been able to track down, so this could be the issue.

-Patrick

danhoskin
Phidgetly
Posts: 45
Joined: Wed Jan 16, 2008 6:05 pm

Re: SBC webservice stops

Postby danhoskin » Thu May 13, 2010 12:36 pm

We are shutting down completely at the end of the day and booting up the SBC and PC in the mornings. During the day it is left connected through the webservice.

AndreGermain
Phidgetly
Posts: 41
Joined: Fri Sep 30, 2011 7:09 am
Contact:

SBC2 webservice stops

Postby AndreGermain » Sat Nov 10, 2012 8:39 am

Hello,

to revive this 1 year old thread, I have the same issue with the SBC2. After a few hours, I find the web service has stopped, and I can re-enable it from the web page without trouble. However, the fact that it stopped causes my automated observatory to lose an entire night's of imaging, and even worst if weather worsens, the facility can't be closed automatically to protect against the elements.

This SBC2 is wired via a router. There is also an SBC1 wireless that goes through the same router. TP-100 CAT 5E to the controlling Windows PC, XP SP3. Latest Phidget loads and libs. The SBC1 is fine. Other Phidgets are via Icron USB (qty 2), in total 13 Phidgets.

Cheers

Laertes
Phidgetly
Posts: 46
Joined: Mon May 05, 2008 10:02 am

Re: SBC webservice stops

Postby Laertes » Thu Feb 07, 2013 4:00 am

Hi,
I am having the same problem with a SBC2.
The web service stops intermitently, and starts without problems if i log on to the device.

The device is in a barn in the north of sweden, can the temperature be an issue (grasping for straws here)?

regards,
/Lars

User avatar
burley
Human-Cyborg Relations
Posts: 441
Joined: Tue Sep 27, 2011 2:37 pm
Location: Calgary
Contact:

Re: SBC webservice stops

Postby burley » Thu Feb 07, 2013 9:39 am

What sort of temperatures are you seeing inside of the barn? The board is rated for 0-70C. You can probably get away with a bit below 0 but if you are seeing substantially below zero temperatures for sustained periods of time then it could definitely be causing issues.
Brian Burley
403-282-7335 ext. 6003
support@phidgets.com

User avatar
Patrick
Lead Developer
Posts: 3046
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: SBC webservice stops

Postby Patrick » Thu Feb 07, 2013 10:36 am

If the webservice is just stopping intermittently, but the SBC is still accessible, then it's not a temperature issue. The webservice does sometimes have long-running stability issues.

-Patrick

Laertes
Phidgetly
Posts: 46
Joined: Mon May 05, 2008 10:02 am

Re: SBC webservice stops

Postby Laertes » Thu Feb 07, 2013 2:09 pm

Hi,
thanks for your quick reply.

I was thinking of a crue workaround:
A http call that starts the damn thing once every hour :)

if I look at the code on the webinterface the following form is used to start the web service.

<form enctype="multipart/form-data" action="/cgi-bin/phidgets-webservice.sh" method="post">
<input type="submit" value="Start" name="startstop" />
</form>

if I submit this using curl and set basic auth on the request, will the service start again?

Have you seen the same problem on the SBC3? Might it help if I upgrade the HW?


/Lars


Return to “General”

Who is online

Users browsing this forum: No registered users and 2 guests