Vista x64 Examples

C, C++, and Visual C++
veeco_jmoore

Vista x64 Examples

Postby veeco_jmoore » Wed May 06, 2009 10:42 am

I am trying to run the current examples under Vista x64 Business. I keep getting this message:

Encoder-simple.exe - Unable To Locate Component
"This application has failed to start because Phidget21.dll was not found. Re-installing the application may fix this problem."

I have tried to re-install, i have copied the Phidget21.dll all over the place so that the exe can find it. Any help would be much appreciated...

User avatar
Patrick
Lead Developer
Posts: 3175
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Vista x64 Examples

Postby Patrick » Wed May 06, 2009 12:22 pm

Did you install the 64-bit version of the MSI? Are you running the encoder-full from the Phidget control panel or from visual studio?

-Patrick

veeco_jmoore

Re: Vista x64 Examples

Postby veeco_jmoore » Thu May 07, 2009 10:10 am

-I have installed the 64-bit version of the msi.
-I can run the Encoder-Full and it runs fine.

The problem happens when trying to use the Encoder-Simple example from the examples install. The project compiles, but shows the error message described previously when attempting to run.

User avatar
Patrick
Lead Developer
Posts: 3175
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Vista x64 Examples

Postby Patrick » Thu May 07, 2009 11:01 am

Strange, it works here. Can you make sure that the example is targeting 'Any CPU' rather then 'x86'? Does encoder-full run from visual studio or just on it's own?

-Patrick


Return to “C/C++”

Who is online

Users browsing this forum: No registered users and 3 guests