Upgrade from max 5 to max 8

Supporting Max/MSP versions 6 and up
rmutt
Phidgetsian
Posts: 5
Joined: Fri Feb 22, 2019 11:33 am
Contact:

Upgrade from max 5 to max 8

Postby rmutt » Fri Feb 22, 2019 11:42 am

I built a museum exhibit in 2011 that used Max 5 which controlled 2 steppers and 1 advanced servo. I would like to upgrade to Max 8 but still use the existing program, motors and control modules. Are there any issues with Max 8? Thanks in advance.

User avatar
mparadis
Site Admin
Posts: 624
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Upgrade from max 5 to max 8

Postby mparadis » Fri Feb 22, 2019 11:59 am

The current version of our libraries (Phidget22) support Max 6 or newer. Your old program is using Phidget21, so I can't guarantee it will work with newer versions of Max. If you decide to update your project to Phidget22, you'll have to make a few modifications to the code. Specifically, we've split apart objects so that each channel on your device has its own object.

rmutt
Phidgetsian
Posts: 5
Joined: Fri Feb 22, 2019 11:33 am
Contact:

Re: Upgrade from max 5 to max 8

Postby rmutt » Sat Mar 02, 2019 4:56 pm

There is one stepper for each control board and there are 2 servos on the advanced servo board. What if I just install a fresh version of Max 5?

jdecoux
Labview Developer
Posts: 84
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Upgrade from max 5 to max 8

Postby jdecoux » Wed Mar 06, 2019 12:29 pm

Having tested it, I can confirm the Phidget 21 libraries will work in Max/MSP 8.

rmutt
Phidgetsian
Posts: 5
Joined: Fri Feb 22, 2019 11:33 am
Contact:

Re: Upgrade from max 5 to max 8

Postby rmutt » Wed Mar 06, 2019 5:29 pm

How about Max 7?

jdecoux
Labview Developer
Posts: 84
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Upgrade from max 5 to max 8

Postby jdecoux » Wed Mar 06, 2019 6:05 pm

Yes. The Phidget21 libraries will work with Max 4.5 and up.

rmutt
Phidgetsian
Posts: 5
Joined: Fri Feb 22, 2019 11:33 am
Contact:

Re: Upgrade from max 5 to max 8

Postby rmutt » Wed Jun 19, 2019 8:20 am

If I upgrade to Phidgets 22, Will my old motors work with the new Vint Boards?

jdecoux
Labview Developer
Posts: 84
Joined: Mon Nov 13, 2017 10:20 am
Contact:

Re: Upgrade from max 5 to max 8

Postby jdecoux » Wed Jun 19, 2019 9:27 am

You will have to update your code to be compatible with the new libraries, but yes, Phidget22 still supports old Phidgets, such as your motor controllers.

rmutt
Phidgetsian
Posts: 5
Joined: Fri Feb 22, 2019 11:33 am
Contact:

Re: Upgrade from max 5 to max 8

Postby rmutt » Wed Jun 19, 2019 11:38 am

So I can continue to use the old controller boards as well as the original motors that I bought? Great! I thought I'd have to change everything out. Really appreciate the prompt response.


Return to “Max/MSP”

Who is online

Users browsing this forum: No registered users and 1 guest