programmin phidgets

Supporting Max/MSP versions 6 and up
pojo

programmin phidgets

Postby pojo » Wed Aug 18, 2010 5:42 am

hi,

for work i have to learn both phidgets and max msp ive only just started playing round with things.
im having trouble connecting the interface kit to the program. i used the patcher from the getting started guide but im not getting data from the board.
i've connected a force sensor (1106) to the interface kit 8/8/8. when i bring up the preference panel and press the sensor the bar moves and i get data but how do i get that data in to the program??? ive tried using the getSeiral command but have had no luck. is there a way of activating it?

please help!
Pojo

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: programmin phidgets

Postby Patrick » Wed Aug 18, 2010 8:52 am

Make sure you don't have any other Phidgets examples running when you open the Max/MSP example. You also need to press the read button to start the sensor data flowing.

-Patrick

pojo

Re: programmin phidgets

Postby pojo » Thu Aug 19, 2010 3:16 am

i tried that it didnt work. i switched to a lcd screen. same thing again, once i open the preference panel i can change the screen settings and send data but when i try on the program it doesnt work. i pressed the toggle button then the set cursor on button nothing happened. on the side theres 3 buttons get version, get status and get serial is that how you link them?

Robert

Re: programmin phidgets

Postby Robert » Thu Aug 19, 2010 9:12 am

Are you getting any error messages in the debug log?

Did you follow the security permissions steps in the getting started manual?

pojo

Re: programmin phidgets

Postby pojo » Thu Aug 19, 2010 9:44 am

yea i followed the guide to the T.. didnt get any error messages, read through the manual twice. i've tried changing sensors but still have had no luck.

Robert

Re: programmin phidgets

Postby Robert » Thu Aug 19, 2010 10:31 am

Can you copy-paste the debug output here?

pojo

Re: programmin phidgets

Postby pojo » Fri Aug 20, 2010 3:10 am

ok... i got the lcd screen working using the example program, but i dont know how or why it started working. for that there isnt anything coming up on the debug screen, what should come up?

What does setSample rate $1 mean? what should i set it to? it says the default is set to -1.

sorry about all the questions. thanks for all your help


Return to “Max/MSP”

Who is online

Users browsing this forum: No registered users and 1 guest