"Preview" of forum post isn't accurate

If you notice any bugs on our site, please report them here.
glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

"Preview" of forum post isn't accurate

Postby glenn » Tue Sep 27, 2011 6:32 pm

Hi,

I just made a post to the forum here, after carefully previewing it to get the formatting right. Then, I hit "submit", and looked at the actual posting... and was surprised to see that it looks quite different from the previewed version! In particular, line endings located differently than in the previewed version.

Seems a little silly to have a "preview" feature if it doesn't actually show the way the final submitted posting will look.

Can provide screenshots if you're interested.

Thanks
Glenn

fraser
Engineering
Posts: 224
Joined: Thu Nov 19, 2009 4:41 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby fraser » Wed Sep 28, 2011 10:07 am

please do, Id like to see them so I can try to replicate it

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Sat Oct 01, 2011 9:21 am

OK, I'm going to make some examples and screenshots now. (I'll test the examples on this thread, so you may have to ignore a few of them until I get a nice one that demonstrates the problem.)

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Sat Oct 01, 2011 9:23 am

====> Test post, please ignore. <=====


Testing a long line to see what happens when posted to the forum blah blah blah foo foo foo foo foo foo foo foo foo foo foo.

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Sat Oct 01, 2011 9:37 am

====> Test #2, please ignore <=====


Second test asdf asdf asfd asdf sad fsadf sad fasd fasd fasd fasdf sa fsadf sadf asdf asdf sad asdf asdf sadf asdf asd fasd fasd fsa fd.

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Sat Oct 01, 2011 9:44 am

OK, here's an example.


This paragraph is being typed as a single long line, i.e. without hitting <return> to force an explicit line ending. What I think you will see in the screenshots (which I will prepare and post after doing this example) is that the line boundaries shown in the preview do not agree with the line boundaries in the actual submitted text as it appears in the forum

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Sat Oct 01, 2011 9:51 am

OK, the previous example shows the problem clearly. Screenshots attached:

ex2_as_composed: Screenshot of the "reply" composition window, prior to previewing.

ex2_as_previewed: Screenshot of the preview of the above message (i.e., obtained by clicking the "Preview" button.)

ex2_as_posted: Screenshot as the posting actually appears in the forum (after clicking "submit).

Note that the "as_previewed" and "as_posted" line breaks are not the same.
Attachments
ex2_as_posted.png
ex2_as_posted.png (99.41 KiB) Viewed 4531 times
ex2_as_previewed.png
ex2_as_previewed.png (111.6 KiB) Viewed 4531 times
ex2_as_composed.png
ex2_as_composed.png (104.57 KiB) Viewed 4531 times

User avatar
Patrick
Lead Developer
Posts: 3028
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: "Preview" of forum post isn't accurate

Postby Patrick » Mon Oct 03, 2011 9:02 am

What's interesting is that your preview picture matches what I see in the forum, but not your forum picture...

What Browser are you using?

The text size seems extra big - have you increased your font size settings?

-Patrick

glenn
Phidgeteer!
Posts: 93
Joined: Sun Sep 05, 2010 4:42 pm
Contact:

Re: "Preview" of forum post isn't accurate

Postby glenn » Tue Oct 04, 2011 6:53 pm

Hi Patrick,

What's interesting is that your preview picture matches what I see in the forum, but not your forum picture...


I just checked to make sure I didn't mislabel the file attachments, but they seem to be right. (In fact, in the "preview" attachment, you can see where it says "preview" at the top, in the blue rectangle.)

What Browser are you using?


Opera 10.63.

The text size seems extra big - have you increased your font size settings?


Nope. Text rendering set to 100%. And page-rendering mode is set to "Author Mode", so it should be rendering in conformance with your CSS.


Return to “Bug Report”

Who is online

Users browsing this forum: No registered users and 1 guest