Page 1 of 1

VB5 Runtime error

Posted: Thu May 22, 2014 11:21 am
by phid7XY60
Hi,
I'm not even sure you can run Phidgets with VB5 but that's what I'm trying. First I validated a 1010 OEM IC version of the 8/8/8 on a protoboard with the interfacekit-simple.exe program you supply precompiled. This ran ok, the phidget reading switchs and voltage dividers, and lighting LEDs.

I used your installer and the app in the taskbar works too. I checked in VB5 and in project/references I see the Phidget Library 2.1 is checked. I also checked project/components and see the Phidget Library 2.1 checked there too.

So I took the VB6 references, like "Retained" out of the .vbp file as VB5 protests about these, and loaded the interfacekit-simple.vbp project into the IDE.

If I try to run the program in interpreted mode from the IDE I get an error 438. "object doesn't support this property or method." Using Debug it shows the program hanging on the following line:

Set phidgetIFK = Controls.Add(phidget21.Com.PhidgetInterfaceKit", "phidgetIFK")

Maybe VB5 is just incompatible, or something else is wrong like my compiler not being pointed in the right direction. Any comments welcome.

Re: VB5 Runtime error

Posted: Thu May 22, 2014 12:16 pm
by Patrick
VB5 is not supported. When we last looked at it 8 years ago, we were not able to get it working.

-Patrick

Re: VB5 Runtime error

Posted: Thu May 22, 2014 12:35 pm
by phid7XY60
Thanks for the reply Patrick, yeah I didn't really think so but I thought I'd give it a try. Fortunately I've been working with Java, as VB is no longer supported by MS.

One last question would be whether the freebie version of .NET is supported?

Re: VB5 Runtime error

Posted: Thu May 22, 2014 1:22 pm
by Patrick
Yes, Visual Studio Express is probably the most common development environment for Phidgets on Windows.

-Patrick