Installing via Run As privileged user is broken)

Legacy support with Phidget21
majiq
Fresh meat
Posts: 2
Joined: Tue Feb 07, 2012 7:25 pm
Contact:

Installing via Run As privileged user is broken)

Postby majiq » Tue Feb 07, 2012 7:49 pm

I had originally typed the post below the dashed line. Having completed my post, I realized one last thing to fix my issue, but I thought I would post for community benefit, and also to log the steps that I took to fix the problem for a bug that I think should be fixed in the installer.

---------------------------------------------------------------------

I previously had the phidget 2.1.6 libraries installed and only recently began changing the datarate. Realizing that there was a changelog entry about the datarate, I ran the update to 2.1.8.

A) I am on Windows XP.
B) I had initially installed using regsvr32.exe
C) I didn't unregister, uninstall, or delete the files before updating

Some combination of this screwed things up. Now when I open a completely empty VB6 project and try to include the Phidget LIbrary 2.1, I get an error. It seems it causes VB6 to create an exception with code 0xc0000005.

Things I've tried: Cleaning the registry - I only left the USB entries. Uninstalling using the installer, unregistering using regsvr32.exe with various timings for restarts. I tried repairing, but it causes the installer to stop at the point where it tries to register the service. The manager seems to work fine (via the Phidget Control Panel in the system tray) or at least it listed the connected phidgets. I didn't look at it past that. I haven't tried using it as a reference instead of a design-time component, simply because I don't have that code in the program that I'm trying to get back to developing. I tried uninstalling, unregistering, and re-registering with copies of the old 2.1.6 files, and that also did not solve things. I have tried every permutation of every trick that I can think of (okay, maybe not true, but it feels like it) unsuccessfully.

Okay, typing that last sentence, I tried the one thing that I didn't throw into the permutation. I had been installing from an unprivileged account using the "Run As" option, but trying to login via the actual privileged account and running the installer fixed the issue. I don't know why this is, but I think that this should get some (minor, late Friday afternoon) attention.

Return to “VB 6.0”

Who is online

Users browsing this forum: No registered users and 1 guest