Problem attaching and problem with auto-install

Legacy support with Phidget21
nibloi

Problem attaching and problem with auto-install

Postby nibloi » Tue Apr 29, 2008 5:37 am

There's appears to be a couple of problems with the Phidgets21 software.

If I install it then immediately run the VB6 sample program the log tells me another process has control of the device and refuses to let me control any of my LEDs (the systray app reports the board as connected, but the VB6 says it's not 'attached'. The systray app similarly refuses to enable any LED controls).

Code: Select all

04/29/08 07:00:39,3544,".\clog.c(46)",INFO,"Enabling logging"
04/29/08 07:00:39,3464,".\cusbwindows.c(258)",INFO,"New Phidget found in CUSBBuildList: \\?\hid#vid_06c2&pid_004a#6&25b4e25d&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}"
04/29/08 07:00:39,3464,".\cusbwindows.c(442)",INFO,"CreateFileW failed with ERROR_SHARING_VIOLATION - probably the Phidget is opened elsewhere."
04/29/08 07:00:39,3464,".\cphidget.c(730)",WARN,"unable to open active device: 1"
04/29/08 07:00:39,3464,".\cusbwindows.c(442)",INFO,"CreateFileW failed with ERROR_SHARING_VIOLATION - probably the Phidget is opened elsewhere."
04/29/08 07:00:39,3464,".\cphidget.c(730)",WARN,"unable to open active device: 1"
04/29/08 07:00:39,3464,".\cusbwindows.c(442)",INFO,"CreateFileW failed with ERROR_SHARING_VIOLATION - probably the Phidget is opened elsewhere."
04/29/08 07:00:39,3464,".\cphidget.c(730)",WARN,"unable to open active device: 1"
04/29/08 07:00:40,3464,".\cusbwindows.c(442)",INFO,"CreateFileW failed with ERROR_SHARING_VIOLATION - probably the Phidget is opened elsewhere."


The other problem appears to be with the auto-install feature. If I disable the Phidgets application (ie uncheck 'Start...with Windows) and reboot when I try to run the VB6 sample code it automatically tries to re-install the Phidgest21 software. It then spots the service it created earlier and backs out the auto-install. This removes the software and leaves the whole Phidgets thing un-usuable. The only option is to reinstall from the ground up.

Can you let me know what I can post/send you to help debug this?

Many thanks!

Ian

nibloi

Postby nibloi » Tue May 06, 2008 5:05 am

The file causing the problem is shared by TrackIR. If I End Task that program the Phidgets app suddenly works fine.

Can you please contact them and compare notes. Like your company, their Installers are a single, self-extracting executable so I don't know what gets installed and used by their programs.

Thanks

Ian

paulmcg
Fresh meat
Posts: 2
Joined: Mon Oct 19, 2009 10:11 pm
Contact:

Re: Problem attaching and problem with auto-install

Postby paulmcg » Mon Oct 19, 2009 10:28 pm

I'm seeing the same problem with Phidgets 2.1 and it constantly wanting to run the .msi file to re-install the software. Here are some additional messages from the Windows event viewer's application log:

"Detection of product '{E9BAD697-9871-4627-8248-2EA080C48327}', feature 'DefaultFeature', component '{2EA7D1C8-25D2-7974-C6E5-83FEF6E6AEE7}' failed. The resource 'HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\Phidget21Manager' does not exist."

"Detection of product '{E9BAD697-9871-4627-8248-2EA080C48327}', feature 'DefaultFeature' failed during request for component '{34E76730-F52D-2970-43A5-8E60B04D81ED}' "

Running regsvr32.exe on C:\Program Files\Phidgets\Phidget21COM.dll didn't fix the problem. I will try and look at the registry to see what happened. I think the answer may be connected to some issue with .NET, but that is just a guess.

Paul


Return to “VB 6.0”

Who is online

Users browsing this forum: No registered users and 1 guest