Page 1 of 1

Drivers/Libraries broken on Raspbian Stretch (RP zero W)

Posted: Sun Nov 05, 2017 12:34 pm
by potter
I followed the instructions for a Debian 32 bit install: and was able to complete the steps without errors. (once I realized I had to use sudo su -c for each command as there were multiple commands in each step requiring root thus a simple sudo did not work. Would have been nice to know.)

However, even though everything seemed to have installed just fine, the Hello World test gives a "Illegal instruction" error. The python examples have the same issue.

I tried purging and reinstalling the libraries but there was no luck.

Any help is appreciated.

Re: Drivers/Libraries broken on Raspbian Stretch (RP zero W)

Posted: Sat Nov 11, 2017 11:14 pm
by potter
I finally got around to attempting a manual install and it worked just fine. Should have started there.

It may be a good idea to retest the Debian stretch repository and install guide. Not that it makes much difference but I don't think this is an appropriate call of wget get on any build:

wget -qO-

Looking forward to testing my 2/2/2 for the first time on a Pi zero.