confirming library extract and configure for raspberry pi

Supporting 2.6 and up
bluwavguy
Phidgetsian
Posts: 5
Joined: Thu Feb 09, 2017 1:10 pm
Contact:

confirming library extract and configure for raspberry pi

Postby bluwavguy » Tue Feb 14, 2017 8:58 am

All,

Its been over 20 years since I was in a unix and c programming environment so I'm not unfamiliar but not at all current...

I've been reading and following the directions and believe the new pi setup is ok, and I can edit and create and run the gcc...with the simple file creation of hello world...but not the phidget HelloWorld as of now..

I've downloaded and extracted the library tar file into a directory under pi/Cprog/Phidget21/libphidget2.1.8.20151217. I can ls and see all of the extracted files.

Following the directions i executed the ./configure command and the output shows all of the checking responses and the last output line is the mssg "configure: error: missing libusb!"

The next step is to run the make command and did so and I get the following:
make: *** No targets specified and no makefile found. Stop.

so either the ./configure did not complete or I've missed something. I do not see the phidget21.h file but do see the phidget21int.h file.

Any help is greatly appreciated and I'm sure I'll have more questions as I move forward.

Thank you,
Brian

frodegill
Phidget Mastermind
Posts: 114
Joined: Thu Mar 04, 2010 2:51 am
Contact:

Re: confirming library extract and configure for raspberry p

Postby frodegill » Tue Feb 14, 2017 9:05 am

bluwavguy wrote:Following the directions i executed the ./configure command and the output shows all of the checking responses and the last output line is the mssg "configure: error: missing libusb!"

sudo apt-get install libusb-1.0-0-dev

( http://www.phidgets.com/docs/OS_-_Linux#Getting_Started_with_Linux )

bluwavguy
Phidgetsian
Posts: 5
Joined: Thu Feb 09, 2017 1:10 pm
Contact:

Re: confirming library extract and configure for raspberry p

Postby bluwavguy » Tue Feb 14, 2017 9:33 am

Thank you, what I missed was extracting all files into the same dir...vs distinct folders.
It appears that I'm back on track as I ran the ./configure in the libusb folder....then the make, then the sudo make install....with no errors....
VR, Brian

bluwavguy
Phidgetsian
Posts: 5
Joined: Thu Feb 09, 2017 1:10 pm
Contact:

Re: confirming library extract and configure for raspberry p

Postby bluwavguy » Tue Feb 14, 2017 10:04 am

Was able to compile and run the HelloWorld file with no errors...I did not have the 1067 connected but received the mssg...Phidget Simple Playground (plug and unplug devices), press enter to end anytime...thank you again. Brian


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 2 guests