Errors found using Phidgets on VMWare but not VirtualBox

Supporting 2.6 and up
aaronjin

Errors found using Phidgets on VMWare but not VirtualBox

Postby aaronjin » Mon Oct 10, 2011 10:58 am

Hi,

I encountered some problems when using a Phidgets device in VMWARE. The guest OS is Ubuntu 11.04 (32bit). The following messages are found when changing relay outputs:

[ 367.050842] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 369.052935] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 371.054974] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 404.035779] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 406.288871] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 408.290959] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 412.723756] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 414.725832] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 416.727942] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 428.850602] usb 2-1: USB disconnect, address 2
[ 437.378329] usb 2-1: new full speed USB device using uhci_hcd and address 4
[ 437.543860] usb 2-1: configuration #1 chosen from 1 choice
[ 437.557889] generic-usb 0003:06C2:0081.0002: hiddev96,hidraw0: USB HID v1.10 Device [Phidgets Inc . PhidgetInterfaceKit] on usb-0000:02:00.0-1/input0
[ 453.311510] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 455.313633] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 len 255 ret -110
[ 457.315683] usb 2-1: usbfs: USBDEVFS_CONTROL failed cmd ph_test rqt 128 rq 6 l

However, it does not happen when VirtualBox is used. Is VMWARE supported for Phidgets devices? If so, is there any additional configurations required to make it work on VMWARE?

Thanks!
Aaron

User avatar
Patrick
Lead Developer
Posts: 3165
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Errors found using Phidgets on VMWare but not VirtualBox

Postby Patrick » Tue Oct 11, 2011 12:14 pm

VMWare has always worked fine here, I'm not sure what could be causing this issue - are you able to use other USB devices in your VMWare guests? Are you able to use Phidgets in a different VMWare guest?

-Patrick

aaronjin

Re: Errors found using Phidgets on VMWare but not VirtualBox

Postby aaronjin » Fri Oct 14, 2011 10:13 am

What VMWare version you are using? I am using 7.1.5

User avatar
Patrick
Lead Developer
Posts: 3165
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Errors found using Phidgets on VMWare but not VirtualBox

Postby Patrick » Fri Oct 14, 2011 12:07 pm

7.1.3


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 2 guests