Problem with Compass 1056 PhidgetSpatial !

Any hardware type questions or problems for all other Phidget devices.
Endri
Fresh meat
Posts: 3
Joined: Wed Nov 16, 2011 1:54 am
Contact:

Problem with Compass 1056 PhidgetSpatial !

Postby Endri » Tue Dec 20, 2011 3:29 am

Hello,

I'm having a probleme with the data compass. So i placed a timer (windows) (20Hz) and every (1/20Hz) i takes the data compass in all axis with the function : result = CPhidgetSpatial_getMagneticField().

So every 16 times,i take a huge data for the 3 axis (like million). This is not possible in reality. So i go inside the function i printed the result. When it works, i take '0' and when its doesn't work i take a '9'. So in the data manual of phidget, it was written : Value unknown exception.

Does anyone have the same problem or know what exactly means this exception ?

Thank you.
Attachments
sauvgarde.csv
(1.83 KiB) Downloaded 93 times

erik
King of the Lab
Posts: 477
Joined: Fri Mar 06, 2009 12:42 pm
Location: Calgary, Canada
Contact:

Re: Problem with Compass 1056 PhidgetSpatial !

Postby erik » Tue Dec 20, 2011 9:14 am

The compass calibrates itself approximately every 2 seconds and data is unavailable for about 28ms. This would be the error that you are seeing.

There's a small blurb in the product manual about this on page 14.

Endri
Fresh meat
Posts: 3
Joined: Wed Nov 16, 2011 1:54 am
Contact:

Re: Problem with Compass 1056 PhidgetSpatial !

Postby Endri » Tue Dec 20, 2011 11:25 am

erik wrote:The compass calibrates itself approximately every 2 seconds and data is unavailable for about 28ms. This would be the error that you are seeing.

There's a small blurb in the product manual about this on page 14.


Thank you. Now its clear.

Best regards,


Return to “All Other Phidgets”

Who is online

Users browsing this forum: No registered users and 1 guest