Stepper motor forward and reverse

Supporting Labview 2012 and up
redferdaze
Fresh meat
Posts: 3
Joined: Sun May 26, 2013 6:36 pm
Contact:

Stepper motor forward and reverse

Postby redferdaze » Sun May 26, 2013 9:08 pm

Hello, I'm trying to write a VI that operates my stepper motor to a certain position, then reverses and returns to the original position. I understand I can just put change the target position back to zero, but I'd like to do this all with one click. I tried to write it using the stepper example just using case structures, but every time I try and set the reverse position on the block diagram Labview freezes, and I have to abort the function.

By the way, I'm using the 1063 stepper control board (and 1018 IF for sending a signal but the part works fine). I would be extremely grateful for any input or advice. Thank you

User avatar
burley
Human-Cyborg Relations
Posts: 441
Joined: Tue Sep 27, 2011 2:37 pm
Location: Calgary
Contact:

Re: Stepper motor forward and reverse

Postby burley » Mon May 27, 2013 7:32 am

Can you attach your VI so we can have a look at it?
Brian Burley
403-282-7335 ext. 6003
support@phidgets.com

redferdaze
Fresh meat
Posts: 3
Joined: Sun May 26, 2013 6:36 pm
Contact:

Re: Stepper motor forward and reverse

Postby redferdaze » Thu May 30, 2013 2:42 pm

Thank you. I've gotten the VI to work one time, and this is how it looked. I have to manually change the velocity, acceleration, current, and both target positions everytime I run the VI, else it will revert automatically to the max values for each. Usually it freezes and the "engage stepper" button becomes unresponsive after I change the Reverse target position value.

It should be attached now
Attachments
Reverse.zip
(61.47 KiB) Downloaded 483 times

User avatar
burley
Human-Cyborg Relations
Posts: 441
Joined: Tue Sep 27, 2011 2:37 pm
Location: Calgary
Contact:

Re: Stepper motor forward and reverse

Postby burley » Fri May 31, 2013 7:19 am

Your VI wont even run for me. It claims there are errors in the block diagram.
Brian Burley
403-282-7335 ext. 6003
support@phidgets.com

redferdaze
Fresh meat
Posts: 3
Joined: Sun May 26, 2013 6:36 pm
Contact:

Re: Stepper motor forward and reverse

Postby redferdaze » Fri May 31, 2013 9:58 am

Hmm. That is weird. Any specific errors? I downloaded the file to check and it runs fine for me.

User avatar
burley
Human-Cyborg Relations
Posts: 441
Joined: Tue Sep 27, 2011 2:37 pm
Location: Calgary
Contact:

Re: Stepper motor forward and reverse

Postby burley » Fri May 31, 2013 10:44 am

I fixed a few broken connections in the block diagram and tried it out. Seems to run normally now. Though I do get a crash when I try to modify the Acceleration REV value. Looks like it isn't connected to anything in the block diagram though.

I am thinking that there is just some messed up wiring in the block diagram. Have a look over all the connections and make sure everything is hooked up properly.
Brian Burley
403-282-7335 ext. 6003
support@phidgets.com


Return to “Labview”

Who is online

Users browsing this forum: No registered users and 4 guests