Problem running Accelerometer Example in Flash CS5

Legacy support with Phidget21
zahhar

Problem running Accelerometer Example in Flash CS5

Postby zahhar » Fri Apr 08, 2011 1:50 am

Hi!

My problem seems to be very simple: I can't run default AS3 code sample for 3-axis Accelerometer (1059) in my Flash CS5. It never fires onAttach event and after open() nothing happens (isAttached returns false). In Phidget Control Panel output I see that request from Flash was authorised, no any error appear neither in Flash nor in Control Panel.

All other AS3 code samples run perfectly on the same computer. The same Accelerometer is accessible from Phidget Control Panel and works well with Python.

System properties are:
Windows XP Pro SP3 32-bit, Phidgets 21 32-bit, Adobe Flash CS5 trial.

Any advise please?

erik
King of the Lab
Posts: 476
Joined: Fri Mar 06, 2009 12:42 pm
Location: Calgary, Canada
Contact:

Re: Problem running Accelerometer Example in Flash CS5

Postby erik » Fri Apr 08, 2011 9:17 am

Are there any other programs open that are trying to use the Accelerometer at the same time? ie., is the Accelerometer example opened from the Phidget Control Panel at the same time you're trying to run the AS3 example? Is your Python program closing the Phidget before exiting?

zahhar

Re: Problem running Accelerometer Example in Flash CS5

Postby zahhar » Tue Apr 12, 2011 8:16 am

Thanks, Erik - problem is solved.
I really had accelerometer opened from Control Panel while running flash example.


Return to “ActionScript 3.0 - Flash CS3 / Flex / AIR”

Who is online

Users browsing this forum: No registered users and 1 guest