Page 1 of 1

Installation Problems

Posted: Mon Dec 08, 2008 4:30 am
by Robbert Ritmeester
Installing Phidget 2.1.5 on the new laptop isn't going well. I can't get stuff to work that worked before. After restarting the computer I get this warning and Phidgets is no more...

Unexpected Exception, Exiting:
Aangevraagde registertoegang is niet toegestaan
(requested register is not allowed),
bij System.ThrowHelper.ThrowSecurityException(ExceptionResourceresource)
bij Microsoft.Win32.RegisterKey.OpenSubKey (String name, Boolean writable)
bij phidget21Manager.ServiceController2.set_ServiceStart(ServiceStart value)
bij phidget21Manager.Form1RemoteUpdateFunc2()


I'm using an updated Vista and Flash AS3 and have already tried it without the Firewall

Anyone? Thanks!


Robbert

Posted: Mon Dec 08, 2008 10:46 am
by Patrick
It looks like you are running under a limited user account? Or perhaps Vista UAC is getting in your way. You can start the phidget webservice from the Windows Services control panel if needed.

-Patrick

Posted: Wed Dec 10, 2008 10:20 am
by Robbert Ritmeester
Thanks Patrick, turning off Vista UAC seems to take care of the problem.
Still, some other issues remain: things I had made that worked before don't work now.

In Output:
1046: Type was not found or was not a compile-time constant: PhidgetErrorEvent.
1046: Type was not found or was not a compile-time constant: PhidgetEvent.
1046: Type was not found or was not a compile-time constant: PhidgetDataEvent.


Using the templates offered by Phidget these error-message don't turn up so their must be something wrong in my code. But how do I find out where? It worked before; are there perhaps any other changes with Vista or in Phidget software?

Robbert

Posted: Wed Dec 10, 2008 10:47 am
by Patrick
do you import com.phidgets.events.*; ?

-Patrick

Posted: Wed Dec 10, 2008 11:11 am
by Robbert Ritmeester
Yes. But then, if I didn't it wouldn't run on my old laptop.
I think I will have to reverse engineer from the template back to what I had made. It isn't very complex. Just some testing with I/O switches.

Robbert

Re: Installation Problems

Posted: Tue May 12, 2009 7:15 am
by floff
Hmmm i am getting a very similar error on a thing that i built myself:

"1046: Type was not found or was not a compile-time constant: PhidgetEncoder."

I checked the location of the Flash-Phidget files, but that seems to be correct.
But if i run one of the example files (PhidgetEncoder) than i works without any problems.

Pretty wierd!

Somebody has a clue?
I am running on Windows XP 32bit, with 3 PhidgetEncoders.

THanks!!
Floris