OS X El Capitan

Supporting 10.7 and up
RobFreitas
Fresh meat
Posts: 1
Joined: Sun Aug 02, 2015 2:59 pm
Contact:

OS X El Capitan

Postby RobFreitas » Sun Aug 02, 2015 3:05 pm

I'm having an issue with a Phidget Temperature sensor board that is acting up in the new beta version of OS X El Capitan. the phidget shows up in the preference pane, but when i click on the phidget it shows up with nothing attached even though the board is connected to two thermocouples. i've tested it in PC environments and it works fine. any thoughts?

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Tue Aug 04, 2015 9:24 am

I haven't tried the new OS yet, I'll download it today and see what's going on.

-Patrick

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Wed Aug 05, 2015 10:46 am

On the latest beta, I'm able to get it working. If a Phidget is plugged in before the system boots, then it cannot be opened, but after unplugging and replugging it opens fine. This seems to be a bug with the Beta OS, but I will pursue the issue with Apple.

I'll be releasing a new installer today which addresses the issues of the installer failing - this is just related to the webservice being installed into /usr/bin, which is no longer allowed.

-Patrick

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Thu Aug 06, 2015 10:03 am

I was using an older Beta. On the latest, it's broken again. I'll continue looking into it.

-Patrick

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Thu Aug 06, 2015 11:41 am

OK, I have tracked down the issue, just waiting on Apple, hopefully will have a working installer in a couple of weeks.

-Patrick

kilpatjr
Fresh meat
Posts: 4
Joined: Sat Aug 22, 2015 11:55 am
Contact:

Re: OS X El Capitan

Postby kilpatjr » Sat Aug 22, 2015 11:57 am

Looks like another OS X El Capitan beta came out this week and the TC still seems to be having issues. How are things looking on your end, Patrick?

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Mon Aug 24, 2015 11:01 am

The latest Phidget release (from Friday the 21st) supports El Capitan.

-Patrick

wegard
Phidgetsian
Posts: 5
Joined: Fri Oct 02, 2015 6:27 am
Contact:

Re: OS X El Capitan

Postby wegard » Fri Oct 02, 2015 6:30 am

Just updated to OSX 10.11 El Capitan, and my RFID-readers stopped working.. Cannot open from System prefPane.. I have the latest drivers (20150821). Anyone having the same issues?

User avatar
Patrick
Lead Developer
Posts: 3064
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: OS X El Capitan

Postby Patrick » Mon Oct 05, 2015 9:22 am

Did you try installing the latest drivers after upgrading to El Capitan? This shouldn't really be necessary. Did you reboot after installing the drivers? I'm not having any issues with the drivers on a clean install of El Capitan, as well as an upgrade from Yosemite. Can you have a look at the Console app (/Applications/Utilities/Console) and see if there are any messages that show up when you try to load the pref pane?

-Patrick

wegard
Phidgetsian
Posts: 5
Joined: Fri Oct 02, 2015 6:27 am
Contact:

Re: OS X El Capitan

Postby wegard » Tue Oct 06, 2015 6:47 am

I've tried re-installing the latest drivers and rebooting the mac several times.. Still no luck in getting the RFID readers working. All other devices work as they should (8/8/8, 0/0/4, 0/16/16). See screenshot of preference pane after I've clicked on the RFID-reader;
https://www.dropbox.com/s/f8m04adh7brpk0b/Skjermbilde%202015-10-05%2014.56.27.png?dl=0
PS: I've tried several RFID-readers - and they all work like they should on a Windows-computer.


Return to “macOS”

Who is online

Users browsing this forum: No registered users and 1 guest