Waiting for attach...Exception 13: Timeout has been exceeded

Supporting 10.7 and up
Roger

Waiting for attach...Exception 13: Timeout has been exceeded

Postby Roger » Sun Apr 03, 2011 8:25 pm

Hello and thanks in advance for any help!

I am beginning a new project using Phidgets on Macintosh under Python. To get things started I ran the sample program MotorControl-simple.py. It outputs the following:
Opening phidget object....
Waiting for attach....
Phidget Exception 13: b'Given timeout has been exceeded.'
Exiting....

Any assistance on why this is not working and what to try would be appreciated. Here are additional details:

1) System is a Power PC G4 Mac running Mac OS X v 10.5.8.

2) For this test I am using a PhidgetServo 3.0 P/N 1001 4-Motor board.

3) The board is powered with an AC adapter. The USB cable is plugged into a port on the computer, not a hub.

4) I am running Python version is 3.2, just downloaded and installed.

5) The Phidget 21 Installer for Mac OS X was run. Phidgets appears in System Preferences. Opening that pane shows the "Phidget Servo Controller 4-motor". Double clicking on that opens up the window with the sliders, and I can position multiple servos with the sliders. The Serial Number is 11427 and the Version is 313.

6) The Python framework module version: 2.1.8.20110330 was installed. I don't think the program would have executed as far as it did if the library could not be found. (I did get an earlier error about the missing framework, before I found the correct directory to install it - but that error is now resolved.)

I am invoking from terminal, from within a test directory which only contains the MotorControl-simple.py program with the command:
python MotorControl-simple.py

I read that because of USB file permissions, one must be logged in as root. I therefore also tried running from the root/superuser login, with the same results. I also tried running from my personal administrator account using:
sudo python MotorControl-simple.py
with the same result.

Since the slider test application accessed from System Preferences successfully operates the servos, it is clearly not a hardware problem. I also tried rebooting and running MotorControl-simple.py without running the test program from System Preferences, just in case that application was not properly unattaching after being closed - with the same negative results.

My setup is fairly generic and straightforward for this test, so I'm hoping for a simple resolution. Any ideas for helping to overcome this initial problem would be greatly appreciated!

Thanks,

Roger

User avatar
Patrick
Lead Developer
Posts: 3077
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Waiting for attach...Exception 13: Timeout has been exce

Postby Patrick » Mon Apr 04, 2011 9:17 am

the motorcontrol example is for the PhidgetMotorControl devices - you want to run the phidgetservo example.

-Patrick


Return to “macOS”

Who is online

Users browsing this forum: No registered users and 1 guest