Adjusting sensitivity in Mac Interface software?

Supporting 10.7 and up
problemarts

Adjusting sensitivity in Mac Interface software?

Postby problemarts » Sat Apr 10, 2010 4:00 pm

Greetings,
I'm using the 1129 sensors with the 8/8/8 and MAX/MSP on a Mac OS X (10.5) machine. I've tried adjusting the sensitivity of the sensors using the "sensitivity" slider in the Interface Kit app in System Preferences. This works so long as the system preferences control panel remains open, but upon closing the panel, the sensitivity reverts instantly back to its default (10). Of course it's necessary to close the control panel in order to release the serial device so that MAX can call on it. Is there a way to adjust the sensitivity in the control panel and have it remember the new number, or a way to adjust the sensitivity through MAX?
Thanks!

User avatar
Patrick
Lead Developer
Posts: 3077
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Adjusting sensitivity in Mac Interface software?

Postby Patrick » Sat Apr 10, 2010 6:33 pm

MaxMSP doesn't use sensitivity, it updates the analog values at the rate you set.

-Patrick

problemarts

Re: Adjusting sensitivity in Mac Interface software?

Postby problemarts » Sat Apr 10, 2010 9:48 pm

Thanks for your reply, Patrick. I have tried adjusting the setSampleRate $1 message with the PhidgetInterfaceKit object in MAX, but it doesn't seem to have much of an effect. Is there a recommended setting that might produce the same effect as increasing sensitivity?

User avatar
Patrick
Lead Developer
Posts: 3077
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Adjusting sensitivity in Mac Interface software?

Postby Patrick » Sun Apr 11, 2010 9:34 am

sensitivity only affects sensor events - Max doesn't use sensor events at all, it just sends you data at the rate you specify, whether or not it has changed. What exactly in the behaviour is not as you'd like? What type of interfacekit are you using?

-Patrick

problemarts

Re: Adjusting sensitivity in Mac Interface software?

Postby problemarts » Sun Apr 11, 2010 7:43 pm

I'm using an 8/8/8 and 1129 touch sensors. For the most part it works pretty well, but occasionally the sensors get "stuck" after they've sensed a touch (registered as 997 or 998) and won't return to a 0 state. Just for comparison, I tested sensor behavior through in the System Preferences interface, where I can adjust sensitivity with the slider, and I noticed that when I move sensitivity from a lower number to a higher number, this problem goes away. So just trying to figure out if there's a way to make that type of adjustment in MAX.

Thanks for help!

User avatar
Patrick
Lead Developer
Posts: 3077
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Adjusting sensitivity in Mac Interface software?

Postby Patrick » Mon Apr 12, 2010 9:31 am

MaxMSP sets sensitivity to 1 automatically, but it doesn't even use it unless you set your data rate to -1 (where it will report any changes as they happen) - otherwise data is sent at the rate that you specify. If your sensor value is not returning to 0, then it's a problem with the sensor, or in the way you're using the sensor.

-Patrick

problemarts

Re: Adjusting sensitivity in Mac Interface software?

Postby problemarts » Tue Apr 13, 2010 3:20 pm

Thanks, this is helpful info! I think it was a problem with one specific sensor - I've received a new batch and I'm not seeing the same issues.


Return to “macOS”

Who is online

Users browsing this forum: No registered users and 2 guests